summaryrefslogtreecommitdiffstats
path: root/ansible_collections/theforeman/foreman/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-18 05:52:22 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-18 05:52:22 +0000
commit38b7c80217c4e72b1d8988eb1e60bb6e77334114 (patch)
tree356e9fd3762877d07cde52d21e77070aeff7e789 /ansible_collections/theforeman/foreman/Makefile
parentAdding upstream version 7.7.0+dfsg. (diff)
downloadansible-38b7c80217c4e72b1d8988eb1e60bb6e77334114.tar.xz
ansible-38b7c80217c4e72b1d8988eb1e60bb6e77334114.zip
Adding upstream version 9.4.0+dfsg.upstream/9.4.0+dfsg
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ansible_collections/theforeman/foreman/Makefile')
-rw-r--r--ansible_collections/theforeman/foreman/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/ansible_collections/theforeman/foreman/Makefile b/ansible_collections/theforeman/foreman/Makefile
index 685424f48..0a5415775 100644
--- a/ansible_collections/theforeman/foreman/Makefile
+++ b/ansible_collections/theforeman/foreman/Makefile
@@ -49,10 +49,12 @@ lint: $(MANIFEST) $(RUNTIME_YML) | tests/test_playbooks/vars/server.yml
ansible-lint -v --offline roles/*
ansible-playbook --syntax-check tests/test_playbooks/*.yml | grep -v '^$$'
flake8 --ignore=E402,W503 --max-line-length=160 plugins/ tests/
- GALAXY_IMPORTER_CONFIG=tests/galaxy-importer.cfg python -m galaxy_importer.main $(NAMESPACE)-$(NAME)-$(VERSION).tar.gz
@echo "Check that there are no changes to $(RUNTIME_YML)"
git diff --exit-code $(RUNTIME_YML)
+galaxy-importer: $(MANIFEST)
+ GALAXY_IMPORTER_CONFIG=tests/galaxy-importer.cfg python -m galaxy_importer.main $(NAMESPACE)-$(NAME)-$(VERSION).tar.gz
+
sanity: $(MANIFEST)
# Fake a fresh git repo for ansible-test
cd $(<D) ; git init ; echo tests > .gitignore ; ansible-test sanity $(SANITY_OPTS) --python $(PYTHON_VERSION)
@@ -88,7 +90,7 @@ clean_%: FORCE $(MANIFEST)
setup: test-setup
test-setup: | tests/test_playbooks/vars/server.yml
- pip install --upgrade --force-reinstall 'pip<23.1'
+ pip install --upgrade pip
pip install --upgrade -r requirements-dev.txt
tests/test_playbooks/vars/server.yml: