summaryrefslogtreecommitdiffstats
path: root/ansible_collections/community/aws/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'ansible_collections/community/aws/pyproject.toml')
-rw-r--r--ansible_collections/community/aws/pyproject.toml43
1 files changed, 43 insertions, 0 deletions
diff --git a/ansible_collections/community/aws/pyproject.toml b/ansible_collections/community/aws/pyproject.toml
new file mode 100644
index 000000000..a3810fdc1
--- /dev/null
+++ b/ansible_collections/community/aws/pyproject.toml
@@ -0,0 +1,43 @@
+[tool.black]
+skip-string-normalization = false
+line-length = 120
+target-version = ['py37', 'py38']
+extend-exclude = '''
+/(
+ | plugins/module_utils/_version.py
+)/
+'''
+
+[tool.darker]
+revision = "origin/main.."
+
+src = [
+ "plugins",
+ "tests/unit",
+ "tests/integration",
+]
+
+[tool.isort]
+profile = "black"
+force_single_line = true
+line_length = 120
+
+src_paths = [
+ "plugins",
+ "tests/unit",
+ "tests/integration",
+]
+
+# Unstable
+skip = [
+ "aws_ssm.py"
+]
+
+sections = ["FUTURE", "STDLIB", "THIRDPARTY", "FIRSTPARTY", "ANSIBLE_CORE", "ANSIBLE_AMAZON_AWS", "ANSIBLE_COMMUNITY_AWS", "LOCALFOLDER"]
+known_third_party = ["botocore", "boto3"]
+known_ansible_core = ["ansible"]
+known_ansible_amazon_aws = ["ansible_collections.amazon.aws"]
+known_ansible_community_aws = ["ansible_collections.community.aws"]
+
+[tool.flynt]
+transform-joins = true