summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-12 08:32:35 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-12 08:32:35 +0000
commit512a73ef7e40be5ec95604bd7a7a41455008f84a (patch)
tree2939e0f00e162bba574ffb976433df9395639b67 /debian/patches
parentMerging upstream version 2.4.59. (diff)
downloadapache2-512a73ef7e40be5ec95604bd7a7a41455008f84a.tar.xz
apache2-512a73ef7e40be5ec95604bd7a7a41455008f84a.zip
Merging debian version 2.4.59-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/fhs_compliance.patch24
-rw-r--r--debian/patches/reproducible_builds.diff2
2 files changed, 11 insertions, 15 deletions
diff --git a/debian/patches/fhs_compliance.patch b/debian/patches/fhs_compliance.patch
index 1d5fc98..986d8bc 100644
--- a/debian/patches/fhs_compliance.patch
+++ b/debian/patches/fhs_compliance.patch
@@ -6,30 +6,26 @@ Last-Update: 2023-10-19
--- a/configure
+++ b/configure
-@@ -41291,17 +41291,17 @@
+@@ -42812,13 +42812,13 @@
+ ap_prefix="${ap_cur}"
- cat >>confdefs.h <<_ACEOF
--#define HTTPD_ROOT "${ap_prefix}"
-+#define HTTPD_ROOT "/etc/apache2"
- _ACEOF
+-printf "%s\n" "#define HTTPD_ROOT \"${ap_prefix}\"" >>confdefs.h
++printf "%s\n" "#define HTTPD_ROOT \"/etc/apache2\"" >>confdefs.h
- cat >>confdefs.h <<_ACEOF
--#define SERVER_CONFIG_FILE "${rel_sysconfdir}/${progname}.conf"
-+#define SERVER_CONFIG_FILE "${progname}.conf"
- _ACEOF
+-printf "%s\n" "#define SERVER_CONFIG_FILE \"${rel_sysconfdir}/${progname}.conf\"" >>confdefs.h
++printf "%s\n" "#define SERVER_CONFIG_FILE \"${progname}.conf\"" >>confdefs.h
- cat >>confdefs.h <<_ACEOF
--#define AP_TYPES_CONFIG_FILE "${rel_sysconfdir}/mime.types"
-+#define AP_TYPES_CONFIG_FILE "mime.types"
- _ACEOF
+-printf "%s\n" "#define AP_TYPES_CONFIG_FILE \"${rel_sysconfdir}/mime.types\"" >>confdefs.h
++printf "%s\n" "#define AP_TYPES_CONFIG_FILE \"mime.types\"" >>confdefs.h
+ perlbin=`$ac_aux_dir/PrintPath perl`
--- a/configure.in
+++ b/configure.in
-@@ -902,11 +902,11 @@
+@@ -928,11 +928,11 @@
echo $MODLIST | $AWK -f $srcdir/build/build-modules-c.awk > modules.c
APR_EXPAND_VAR(ap_prefix, $prefix)
diff --git a/debian/patches/reproducible_builds.diff b/debian/patches/reproducible_builds.diff
index 36f71e2..8f48922 100644
--- a/debian/patches/reproducible_builds.diff
+++ b/debian/patches/reproducible_builds.diff
@@ -18,7 +18,7 @@ Last-Update: 2015-08-11
-#endif
+static const char server_built[] = BUILD_DATETIME;
- AP_DECLARE(const char *) ap_get_server_built()
+ AP_DECLARE(const char *) ap_get_server_built(void)
{
--- a/server/Makefile.in
+++ b/server/Makefile.in