summaryrefslogtreecommitdiffstats
path: root/Dockerfile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:59:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 19:59:18 +0000
commitfa60720fe95711a68dd4f1cb57fbc79fc6fc2e5c (patch)
treea8712923a49e76a6241f151af877900e056ce65d /Dockerfile
parentInitial commit. (diff)
downloadasciinema-fa60720fe95711a68dd4f1cb57fbc79fc6fc2e5c.tar.xz
asciinema-fa60720fe95711a68dd4f1cb57fbc79fc6fc2e5c.zip
Adding upstream version 2.4.0.upstream/2.4.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Dockerfile')
-rw-r--r--Dockerfile38
1 files changed, 38 insertions, 0 deletions
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 0000000..0fc2b8c
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,38 @@
+# syntax=docker/dockerfile:1.3
+
+FROM docker.io/library/ubuntu:22.04
+
+ENV DEBIAN_FRONTEND="noninteractive"
+
+RUN apt-get update \
+ && apt-get install -y \
+ ca-certificates \
+ locales \
+ python3 \
+ python3-pip \
+ && localedef \
+ -i en_US \
+ -c \
+ -f UTF-8 \
+ -A /usr/share/locale/locale.alias \
+ en_US.UTF-8
+
+COPY pyproject.toml setup.cfg *.md /usr/src/app/
+COPY doc/*.md /usr/src/app/doc/
+COPY man/asciinema.1 /usr/src/app/man/
+COPY asciinema/ /usr/src/app/asciinema/
+COPY README.md LICENSE /usr/src/app/
+
+WORKDIR /usr/src/app
+
+RUN pip3 install .
+
+WORKDIR /root
+
+ENV LANG="en_US.utf8"
+ENV SHELL="/bin/bash"
+
+ENTRYPOINT ["/usr/local/bin/asciinema"]
+CMD ["--help"]
+
+# vim:ft=dockerfile