summaryrefslogtreecommitdiffstats
path: root/man
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 19:28:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-27 19:28:49 +0000
commit9f9b6e7b09a54b2c8089de33c975086104956249 (patch)
tree29445e7621f24b9ff64b2ea59a434ef0985a143e /man
parentInitial commit. (diff)
downloadautoconf-dickey-9f9b6e7b09a54b2c8089de33c975086104956249.tar.xz
autoconf-dickey-9f9b6e7b09a54b2c8089de33c975086104956249.zip
Adding upstream version 2.52+20231210.upstream/2.52+20231210
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'man')
-rw-r--r--man/Makefile.in263
-rw-r--r--man/autoconf.1109
-rw-r--r--man/autoconf.x3
-rw-r--r--man/autoheader.183
-rw-r--r--man/autoheader.x3
-rw-r--r--man/autoreconf.187
-rw-r--r--man/autoreconf.x2
-rw-r--r--man/autoscan.160
-rw-r--r--man/autoscan.x3
-rw-r--r--man/autoupdate.169
-rw-r--r--man/autoupdate.x3
-rw-r--r--man/common.x10
-rw-r--r--man/ifnames.150
-rw-r--r--man/ifnames.x3
14 files changed, 748 insertions, 0 deletions
diff --git a/man/Makefile.in b/man/Makefile.in
new file mode 100644
index 0000000..d4f66e3
--- /dev/null
+++ b/man/Makefile.in
@@ -0,0 +1,263 @@
+# Copyright 2010-2012,2023 Thomas E. Dickey
+# Copyright 1994, 1995, 1996, 1997, 1998, 1999, 2000, 2001
+# Free Software Foundation, Inc.
+# This Makefile.in is free software; the Free Software Foundation
+# gives unlimited permission to copy and/or distribute it,
+# with or without modifications, as long as this notice is preserved.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY, to the extent permitted by law; without
+# even the implied warranty of MERCHANTABILITY or FITNESS FOR A
+# PARTICULAR PURPOSE.
+
+@SET_MAKE@
+
+SHELL = @SHELL@
+
+srcdir = @srcdir@
+top_srcdir = @top_srcdir@
+VPATH = @srcdir@
+prefix = @prefix@
+exec_prefix = @exec_prefix@
+
+bindir = @bindir@
+sbindir = @sbindir@
+libexecdir = @libexecdir@
+datarootdir = @datarootdir@
+datadir = @datadir@
+sysconfdir = @sysconfdir@
+sharedstatedir = @sharedstatedir@
+localstatedir = @localstatedir@
+libdir = @libdir@
+infodir = @infodir@
+mandir = @mandir@
+includedir = @includedir@
+oldincludedir = /usr/include
+pkgdatadir = $(datadir)/@PACKAGE@
+pkglibdir = $(libdir)/@PACKAGE@
+pkgincludedir = $(includedir)/@PACKAGE@
+top_builddir = ..
+
+AUTOCONF = @AUTOCONF@
+AUTOHEADER = @AUTOHEADER@
+
+INSTALL = @INSTALL@
+INSTALL_PROGRAM = @INSTALL_PROGRAM@
+INSTALL_DATA = @INSTALL_DATA@
+INSTALL_SCRIPT = @INSTALL_SCRIPT@
+INSTALL_HEADER = $(INSTALL_DATA)
+transform = @program_transform_name@
+NORMAL_INSTALL = :
+PRE_INSTALL = :
+POST_INSTALL = :
+NORMAL_UNINSTALL = :
+PRE_UNINSTALL = :
+POST_UNINSTALL = :
+AWK = @AWK@
+EXPR = @EXPR@
+HELP2MAN = @HELP2MAN@
+M4 = @M4@
+PACKAGE = @PACKAGE@
+PACKAGE_NAME = @PACKAGE_NAME@
+PERL = @PERL@
+PERLSCRIPTS = @PERLSCRIPTS@
+VERSION = @VERSION@
+
+man_MANS = autoconf.1 autoreconf.1 autoheader.1 autoupdate.1 ifnames.1 \
+autoscan.1
+
+
+man_aux = autoconf.x autoreconf.x autoheader.x autoupdate.x ifnames.x \
+autoscan.x
+
+
+EXTRA_DIST = $(man_MANS) $(man_aux) common.x
+MAINTAINERCLEANFILES = $(man_MANS)
+
+# Depend on configure.ac to get version number changes.
+common_dep = $(top_srcdir)/configure.ac $(srcdir)/common.x
+
+SUFFIXES = .x .1
+subdir = man
+CONFIG_CLEAN_FILES =
+DIST_SOURCES =
+
+NROFF = nroff
+MANS = $(man_MANS)
+DIST_COMMON = Makefile.am Makefile.in
+all: all-am
+
+.SUFFIXES:
+.SUFFIXES: .x .1
+
+Makefile: $(srcdir)/Makefile.in $(top_builddir)/config.status
+ cd $(top_builddir) && \
+ CONFIG_HEADERS= CONFIG_LINKS= \
+ CONFIG_FILES=$(subdir)/$@ $(SHELL) ./config.status
+uninstall-info-am:
+
+man1dir = $(mandir)/man1
+install-man1: $(man1_MANS) $(man_MANS)
+ @$(NORMAL_INSTALL)
+ mkdir -p $(DESTDIR)$(man1dir)
+ @list='$(man1_MANS) $(dist_man1_MANS) $(nodist_man1_MANS)'; \
+ l2='$(man_MANS) $(dist_man_MANS) $(nodist_man_MANS)'; \
+ for i in $$l2; do \
+ case "$$i" in \
+ *.1*) list="$$list $$i" ;; \
+ esac; \
+ done; \
+ for i in $$list; do \
+ if test -f $(srcdir)/$$i; then file=$(srcdir)/$$i; \
+ else file=$$i; fi; \
+ ext=`echo $$i | sed -e 's/^.*\\.//'`; \
+ inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
+ inst=`echo $$inst | sed -e 's/^.*\///'`; \
+ inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+ echo " $(INSTALL_DATA) $$file $(DESTDIR)$(man1dir)/$$inst"; \
+ $(INSTALL_DATA) $$file $(DESTDIR)$(man1dir)/$$inst; \
+ done
+uninstall-man1:
+ @$(NORMAL_UNINSTALL)
+ @list='$(man1_MANS) $(dist_man1_MANS) $(nodist_man1_MANS)'; \
+ l2='$(man_MANS) $(dist_man_MANS) $(nodist_man_MANS)'; \
+ for i in $$l2; do \
+ case "$$i" in \
+ *.1*) list="$$list $$i" ;; \
+ esac; \
+ done; \
+ for i in $$list; do \
+ ext=`echo $$i | sed -e 's/^.*\\.//'`; \
+ inst=`echo $$i | sed -e 's/\\.[0-9a-z]*$$//'`; \
+ inst=`echo $$inst | sed -e 's/^.*\///'`; \
+ inst=`echo $$inst | sed '$(transform)'`.$$ext; \
+ echo " rm -f $(DESTDIR)$(man1dir)/$$inst"; \
+ rm -f $(DESTDIR)$(man1dir)/$$inst; \
+ done
+tags: TAGS
+TAGS:
+
+
+DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
+
+top_distdir = ..
+distdir = $(top_distdir)/$(PACKAGE)-$(VERSION)
+
+distdir: $(DISTFILES)
+ @for file in $(DISTFILES); do \
+ if test -f $$file; then d=.; else d=$(srcdir); fi; \
+ dir=`echo "$$file" | sed -e 's,/[^/]*$$,,'`; \
+ if test "$$dir" != "$$file" && test "$$dir" != "."; then \
+ mkdir -p "$(distdir)/$$dir"; \
+ fi; \
+ if test -d $$d/$$file; then \
+ cp -pR $$d/$$file $(distdir) \
+ || exit 1; \
+ else \
+ test -f $(distdir)/$$file \
+ || cp -p $$d/$$file $(distdir)/$$file \
+ || exit 1; \
+ fi; \
+ done
+check-am: all-am
+check: check-am
+all-am: Makefile $(MANS)
+
+installdirs:
+ mkdir -p $(DESTDIR)$(man1dir)
+
+install: install-am
+install-exec: install-exec-am
+install-data: install-data-am
+uninstall: uninstall-am
+
+install-am: all-am
+ @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
+
+installcheck: installcheck-am
+install-strip:
+ $(MAKE) $(AM_MAKEFLAGS) INSTALL_PROGRAM="$(INSTALL_STRIP_PROGRAM)" \
+ `test -z '$(STRIP)' || \
+ echo "INSTALL_PROGRAM_ENV=STRIPPROG='$(STRIP)'"` install
+mostlyclean-generic:
+
+clean-generic:
+
+distclean-generic:
+ -rm -f Makefile $(CONFIG_CLEAN_FILES) stamp-h stamp-h[0-9]*
+
+maintainer-clean-generic:
+ @echo "This command is intended for maintainers to use"
+ @echo "it deletes files that may require special tools to rebuild."
+ -test -z "$(MAINTAINERCLEANFILES)" || rm -f $(MAINTAINERCLEANFILES)
+clean: clean-am
+
+clean-am: clean-generic mostlyclean-am
+
+distclean: distclean-am
+
+distclean-am: clean-am distclean-generic
+
+dvi: dvi-am
+
+dvi-am:
+
+info: info-am
+
+info-am:
+
+install-data-am: install-man
+
+install-exec-am:
+
+install-info: install-info-am
+
+install-man: install-man1
+
+installcheck-am:
+
+maintainer-clean: maintainer-clean-am
+
+maintainer-clean-am: distclean-am maintainer-clean-generic
+
+mostlyclean: mostlyclean-am
+
+mostlyclean-am: mostlyclean-generic
+
+uninstall-am: uninstall-info-am uninstall-man
+
+uninstall-man: uninstall-man1
+
+.PHONY: all all-am check check-am clean clean-generic distclean \
+ distclean-generic distdir dvi dvi-am info info-am install \
+ install-am install-data install-data-am install-exec \
+ install-exec-am install-info install-info-am install-man \
+ install-man1 install-strip installcheck installcheck-am \
+ installdirs maintainer-clean maintainer-clean-generic \
+ mostlyclean mostlyclean-generic uninstall uninstall-am \
+ uninstall-info-am uninstall-man uninstall-man1
+
+autoconf.1: $(common_dep) $(srcdir)/autoconf.x $(top_srcdir)/autoconf.in
+autoreconf.1: $(common_dep) $(srcdir)/autoreconf.x $(top_srcdir)/autoreconf.in
+autoheader.1: $(common_dep) $(srcdir)/autoheader.x $(top_srcdir)/autoheader.in
+autoupdate.1: $(common_dep) $(srcdir)/autoupdate.x $(top_srcdir)/autoupdate.in
+ifnames.1: $(common_dep) $(srcdir)/ifnames.x $(top_srcdir)/ifnames.in
+autoscan.1: $(common_dep) $(srcdir)/autoscan.x $(top_srcdir)/autoscan.in
+
+.x.1:
+ test -f $(top_builddir)/$* && prog=$(top_builddir)/$*; \
+ test -f $(top_srcdir)/$* && prog=$(top_srcdir)/$*; \
+ test -f $(top_srcdir)/config/$* && prog=$(top_srcdir)/config/$*; \
+ if test -n "$$prog"; then \
+ echo "Updating man page $@"; \
+ $(HELP2MAN) \
+ --include=$(srcdir)/$*.x \
+ --include=$(srcdir)/common.x \
+ --output=$@ $$prog; \
+ else \
+ echo "WARNING: The man page $@ cannot be updated yet."; \
+ echo " Retry once the corresponding executable is built."; \
+ fi
+# Tell versions [3.59,3.63) of GNU make to not export all variables.
+# Otherwise a system limit (for SysV at least) may be exceeded.
+.NOEXPORT:
diff --git a/man/autoconf.1 b/man/autoconf.1
new file mode 100644
index 0000000..b66ea62
--- /dev/null
+++ b/man/autoconf.1
@@ -0,0 +1,109 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.48.1.
+.TH AUTOCONF "1" "December 2023" "GNU Autoconf 2.52.20231210" "User Commands"
+.SH NAME
+autoconf \- Generate configuration scripts
+.SH SYNOPSIS
+.B autoconf
+[\fI\,OPTION\/\fR] ... [\fI\,TEMPLATE-FILE\/\fR]
+.SH DESCRIPTION
+Generate a configuration script from a TEMPLATE\-FILE if given, or
+`configure.ac' if present, or else `configure.in'. Output is sent
+to the standard output if TEMPLATE\-FILE is given, else into
+`configure'.
+.SS "Operation modes:"
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+print this help, then exit
+.TP
+\fB\-V\fR, \fB\-\-version\fR
+print version number, then exit
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+verbosely report processing
+.TP
+\fB\-d\fR, \fB\-\-debug\fR
+don't remove temporary files
+.TP
+\fB\-o\fR, \fB\-\-output\fR=\fI\,FILE\/\fR
+save output in FILE (stdout is the default)
+.TP
+\fB\-W\fR, \fB\-\-warnings\fR=\fI\,CATEGORY\/\fR
+report the warnings falling in CATEGORY [syntax]
+.SH OPTIONS
+.TP
+\fB\-opt\-functions\fR
+use shell\-functions to reduce repetition
+.SS "Warning categories include:"
+.TP
+`cross'
+cross compilation issues
+.TP
+`obsolete'
+obsolete constructs
+.TP
+`syntax'
+dubious syntactic constructs
+.TP
+`all'
+all the warnings
+.TP
+`no\-CATEGORY'
+turn off the warnings on CATEGORY
+.TP
+`none'
+turn off all the warnings
+.TP
+`error'
+warnings are error
+.PP
+The environment variable `WARNINGS' is honored.
+.SS "Library directories:"
+.TP
+\fB\-A\fR, \fB\-\-autoconf\-dir\fR=\fI\,ACDIR\/\fR
+Autoconf's macro files location (rarely needed)
+.TP
+\fB\-l\fR, \fB\-\-localdir\fR=\fI\,DIR\/\fR
+location of the `aclocal.m4' file
+.SS "Tracing:"
+.TP
+\fB\-t\fR, \fB\-\-trace\fR=\fI\,MACRO\/\fR
+report the list of calls to MACRO
+.TP
+\fB\-i\fR, \fB\-\-initialization\fR
+also trace Autoconf's initialization process
+.PP
+In tracing mode, no configuration script is created.
+.SH AUTHOR
+Written by David J. MacKenzie.
+.SH "REPORTING BUGS"
+Report bugs to <dickey@invisible\-island.net>.
+.SH COPYRIGHT
+Copyright 2003\-2022,2023 Thomas E. Dickey
+.br
+Copyright 1992, 1993, 1994, 1996, 1999, 2000, 2001
+Free Software Foundation, Inc.
+.br
+This is free software; see the source for copying conditions. There is NO
+warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+.BR autoconf (1),
+.BR autoreconf (1),
+.BR autoupdate (1),
+.BR autoheader (1),
+.BR autoscan (1),
+.BR config.guess (1),
+.BR config.sub (1),
+.BR ifnames (1),
+.BR libtool (1).
+.PP
+The full documentation for
+.B autoconf
+is maintained as a Texinfo manual. If the
+.B info
+and
+.B autoconf
+programs are properly installed at your site, the command
+.IP
+.B info autoconf
+.PP
+should give you access to the complete manual.
diff --git a/man/autoconf.x b/man/autoconf.x
new file mode 100644
index 0000000..615d2e5
--- /dev/null
+++ b/man/autoconf.x
@@ -0,0 +1,3 @@
+[name]
+autoconf \- Generate configuration scripts
+
diff --git a/man/autoheader.1 b/man/autoheader.1
new file mode 100644
index 0000000..07ddb0c
--- /dev/null
+++ b/man/autoheader.1
@@ -0,0 +1,83 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.48.1.
+.TH AUTOHEADER "1" "December 2023" "GNU Autoconf 2.52.20231210" "User Commands"
+.SH NAME
+autoheader \- Create a template header for configure
+.SH SYNOPSIS
+.B autoheader
+[\fI\,OPTION\/\fR] ... [\fI\,TEMPLATE-FILE\/\fR]
+.SH DESCRIPTION
+Create a template file of C `#define' statements for `configure' to
+use. To this end, scan TEMPLATE\-FILE, or `configure.ac' if present,
+or else `configure.in'.
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+print this help, then exit
+.TP
+\fB\-V\fR, \fB\-\-version\fR
+print version number, then exit
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+verbosely report processing
+.TP
+\fB\-d\fR, \fB\-\-debug\fR
+don't remove temporary files
+.TP
+\fB\-W\fR, \fB\-\-warnings\fR=\fI\,CATEGORY\/\fR
+report the warnings falling in CATEGORY
+.SS "Warning categories include:"
+.TP
+`obsolete'
+obsolete constructs
+.TP
+`all'
+all the warnings
+.TP
+`no\-CATEGORY'
+turn off the warnings on CATEGORY
+.TP
+`none'
+turn off all the warnings
+.TP
+`error'
+warnings are error
+.SS "Library directories:"
+.TP
+\fB\-A\fR, \fB\-\-autoconf\-dir\fR=\fI\,ACDIR\/\fR
+Autoconf's macro files location (rarely needed)
+.TP
+\fB\-l\fR, \fB\-\-localdir\fR=\fI\,DIR\/\fR
+location of `aclocal.m4' and `acconfig.h'
+.SH AUTHOR
+Written by Roland McGrath.
+.SH "REPORTING BUGS"
+Report bugs to <dickey@invisible\-island.net>.
+.SH COPYRIGHT
+Copyright 2010\-2012,2021 Thomas E. Dickey
+.br
+Copyright 1992, 1993, 1994, 1996, 1998, 1999, 2000, 2001
+Free Software Foundation, Inc.
+.br
+This is free software; see the source for copying conditions. There is NO
+warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+.BR autoconf (1),
+.BR autoreconf (1),
+.BR autoupdate (1),
+.BR autoheader (1),
+.BR autoscan (1),
+.BR config.guess (1),
+.BR config.sub (1),
+.BR ifnames (1),
+.BR libtool (1).
+.PP
+The full documentation for
+.B autoheader
+is maintained as a Texinfo manual. If the
+.B info
+and
+.B autoheader
+programs are properly installed at your site, the command
+.IP
+.B info autoheader
+.PP
+should give you access to the complete manual.
diff --git a/man/autoheader.x b/man/autoheader.x
new file mode 100644
index 0000000..a3e0eba
--- /dev/null
+++ b/man/autoheader.x
@@ -0,0 +1,3 @@
+[name]
+autoheader \- Create a template header for configure
+
diff --git a/man/autoreconf.1 b/man/autoreconf.1
new file mode 100644
index 0000000..a98c46f
--- /dev/null
+++ b/man/autoreconf.1
@@ -0,0 +1,87 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.48.1.
+.TH AUTORECONF "1" "December 2023" "GNU Autoconf 2.52.20231210" "User Commands"
+.SH NAME
+autoreconf \- Update generated configuration files
+.SH SYNOPSIS
+.B autoreconf
+[\fI\,OPTION\/\fR] ... [\fI\,TEMPLATE-FILE\/\fR]
+.SH DESCRIPTION
+Run `autoconf' and `autoheader' where appropriate) repeatedly to
+remake the Autoconf `configure' scripts and configuration header
+templates in the directory tree rooted at the current directory.
+.PP
+By default, it only remakes those files that are older than their
+predecessors. If you install a new version of Autoconf, running
+`autoreconf' remakes all of the files by giving it the `\-\-force'
+option.
+.SS "Operation modes:"
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+print this help, then exit
+.TP
+\fB\-V\fR, \fB\-\-version\fR
+print version number, then exit
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+verbosely report processing
+.TP
+\fB\-d\fR, \fB\-\-debug\fR
+don't remove temporary files
+.TP
+\fB\-f\fR, \fB\-\-force\fR
+consider every files are obsolete
+.TP
+\fB\-i\fR, \fB\-\-install\fR
+copy missing auxiliary files
+.TP
+\fB\-s\fR, \fB\-\-symlink\fR
+instead of copying, install symbolic links
+.PP
+The option `\-\-install' is similar to the option `\-\-add\-missing' in
+other tools.
+.SS "Library directories:"
+.TP
+\fB\-A\fR, \fB\-\-autoconf\-dir\fR=\fI\,ACDIR\/\fR
+Autoconf's macro files location (rarely needed)
+.TP
+\fB\-l\fR, \fB\-\-localdir\fR=\fI\,DIR\/\fR
+location of `aclocal.m4' and `acconfig.h'
+.TP
+\fB\-M\fR, \fB\-\-m4dir\fR=\fI\,M4DIR\/\fR
+this package's Autoconf extensions
+.PP
+Unless specified, heuristics try to compute `M4DIR' from the `Makefile.am',
+or defaults to `m4' if it exists.
+.PP
+The environment variables AUTOCONF and AUTOHEADER are honored.
+.SH AUTHOR
+Written by David J. MacKenzie.
+.SH "REPORTING BUGS"
+Report bugs to <dickey@invisible\-island.net>.
+.SH COPYRIGHT
+Copyright 1994, 1999, 2000 Free Software Foundation, Inc.
+.br
+This is free software; see the source for copying conditions. There is NO
+warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+.BR autoconf (1),
+.BR autoreconf (1),
+.BR autoupdate (1),
+.BR autoheader (1),
+.BR autoscan (1),
+.BR config.guess (1),
+.BR config.sub (1),
+.BR ifnames (1),
+.BR libtool (1).
+.PP
+The full documentation for
+.B autoreconf
+is maintained as a Texinfo manual. If the
+.B info
+and
+.B autoreconf
+programs are properly installed at your site, the command
+.IP
+.B info autoreconf
+.PP
+should give you access to the complete manual.
diff --git a/man/autoreconf.x b/man/autoreconf.x
new file mode 100644
index 0000000..89d4261
--- /dev/null
+++ b/man/autoreconf.x
@@ -0,0 +1,2 @@
+[name]
+autoreconf \- Update generated configuration files
diff --git a/man/autoscan.1 b/man/autoscan.1
new file mode 100644
index 0000000..8252ae6
--- /dev/null
+++ b/man/autoscan.1
@@ -0,0 +1,60 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.48.1.
+.TH AUTOSCAN "1" "December 2023" "GNU Autoconf 2.52.20231210" "User Commands"
+.SH NAME
+autoscan \- Generate a preliminary configure.in
+.SH SYNOPSIS
+.B autoscan
+[\fI\,OPTION\/\fR] ... [\fI\,SRCDIR\/\fR]
+.SH DESCRIPTION
+Examine source files in the directory tree rooted at SRCDIR, or the
+current directory if none is given. Search the source files for
+common portability problems, check for incompleteness of
+`configure.ac', and create a file `configure.scan' which is a
+preliminary `configure.ac' for that package.
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+print this help, then exit
+.TP
+\fB\-V\fR, \fB\-\-version\fR
+print version number, then exit
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+verbosely report processing
+.SS "Library directories:"
+.TP
+\fB\-A\fR, \fB\-\-autoconf\-dir\fR=\fI\,ACDIR\/\fR
+Autoconf's files location (rarely needed)
+.TP
+\fB\-l\fR, \fB\-\-localdir\fR=\fI\,DIR\/\fR
+location of `aclocal.m4' and `acconfig.h'
+.SH AUTHOR
+Written by David J. MacKenzie.
+.SH "REPORTING BUGS"
+Report bugs to <dickey@invisible\-island.net>.
+.SH COPYRIGHT
+Copyright 1994, 1999, 2000, 2001 Free Software Foundation, Inc.
+.br
+This is free software; see the source for copying conditions. There is NO
+warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+.BR autoconf (1),
+.BR autoreconf (1),
+.BR autoupdate (1),
+.BR autoheader (1),
+.BR autoscan (1),
+.BR config.guess (1),
+.BR config.sub (1),
+.BR ifnames (1),
+.BR libtool (1).
+.PP
+The full documentation for
+.B autoscan
+is maintained as a Texinfo manual. If the
+.B info
+and
+.B autoscan
+programs are properly installed at your site, the command
+.IP
+.B info autoscan
+.PP
+should give you access to the complete manual.
diff --git a/man/autoscan.x b/man/autoscan.x
new file mode 100644
index 0000000..ce120eb
--- /dev/null
+++ b/man/autoscan.x
@@ -0,0 +1,3 @@
+[name]
+autoscan \- Generate a preliminary configure.in
+
diff --git a/man/autoupdate.1 b/man/autoupdate.1
new file mode 100644
index 0000000..0d1f5dd
--- /dev/null
+++ b/man/autoupdate.1
@@ -0,0 +1,69 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.48.1.
+.TH AUTOUPDATE "1" "December 2023" "GNU Autoconf 2.52.20231210" "User Commands"
+.SH NAME
+autoupdate \- Update a configure.in to a newer Autoconf
+.SH SYNOPSIS
+.B autoupdate
+[\fI\,OPTION\/\fR] ... [\fI\,TEMPLATE-FILE\/\fR...]
+.SH DESCRIPTION
+Update the TEMPLATE\-FILE... if given, or `configure.ac' if present,
+or else `configure.in', to the syntax of the current version of
+Autoconf. The original files are backed up.
+.SS "Operation modes:"
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+print this help, then exit
+.TP
+\fB\-V\fR, \fB\-\-version\fR
+print version number, then exit
+.TP
+\fB\-v\fR, \fB\-\-verbose\fR
+verbosely report processing
+.TP
+\fB\-d\fR, \fB\-\-debug\fR
+don't remove temporary files
+.SS "Library directories:"
+.TP
+\fB\-A\fR, \fB\-\-autoconf\-dir\fR=\fI\,ACDIR\/\fR
+Autoconf's macro files location (rarely needed)
+.TP
+\fB\-l\fR, \fB\-\-localdir\fR=\fI\,DIR\/\fR
+location of `aclocal.m4'
+.SS "Environment variables:"
+.TP
+M4
+GNU M4 1.4 or above
+.TP
+AUTOCONF
+autoconf 2.52.20231210
+.SH AUTHOR
+Written by David J. MacKenzie and Akim Demaille.
+.SH "REPORTING BUGS"
+Report bugs to <dickey@invisible\-island.net>.
+.SH COPYRIGHT
+Copyright 1994, 1999, 2000, 2001 Free Software Foundation, Inc.
+.br
+This is free software; see the source for copying conditions. There is NO
+warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+.BR autoconf (1),
+.BR autoreconf (1),
+.BR autoupdate (1),
+.BR autoheader (1),
+.BR autoscan (1),
+.BR config.guess (1),
+.BR config.sub (1),
+.BR ifnames (1),
+.BR libtool (1).
+.PP
+The full documentation for
+.B autoupdate
+is maintained as a Texinfo manual. If the
+.B info
+and
+.B autoupdate
+programs are properly installed at your site, the command
+.IP
+.B info autoupdate
+.PP
+should give you access to the complete manual.
diff --git a/man/autoupdate.x b/man/autoupdate.x
new file mode 100644
index 0000000..23aa18c
--- /dev/null
+++ b/man/autoupdate.x
@@ -0,0 +1,3 @@
+[name]
+autoupdate \- Update a configure.in to a newer Autoconf
+
diff --git a/man/common.x b/man/common.x
new file mode 100644
index 0000000..2275c16
--- /dev/null
+++ b/man/common.x
@@ -0,0 +1,10 @@
+[see also]
+.BR autoconf (1),
+.BR autoreconf (1),
+.BR autoupdate (1),
+.BR autoheader (1),
+.BR autoscan (1),
+.BR config.guess (1),
+.BR config.sub (1),
+.BR ifnames (1),
+.BR libtool (1).
diff --git a/man/ifnames.1 b/man/ifnames.1
new file mode 100644
index 0000000..1fd3961
--- /dev/null
+++ b/man/ifnames.1
@@ -0,0 +1,50 @@
+.\" DO NOT MODIFY THIS FILE! It was generated by help2man 1.48.1.
+.TH IFNAMES "1" "December 2023" "GNU Autoconf 2.52.20231210" "User Commands"
+.SH NAME
+ifnames \- Extract CPP conditionals from a set of files
+.SH SYNOPSIS
+.B ifnames
+[\fI\,OPTION\/\fR] ... [\fI\,FILE\/\fR] ...
+.SH DESCRIPTION
+Scan all of the C source FILES (or the standard input, if none are
+given) and write to the standard output a sorted list of all the
+identifiers that appear in those files in `#if', `#elif', `#ifdef', or
+`#ifndef' directives. Print each identifier on a line, followed by a
+space\-separated list of the files in which that identifier occurs.
+.TP
+\fB\-h\fR, \fB\-\-help\fR
+print this help, then exit
+.TP
+\fB\-V\fR, \fB\-\-version\fR
+print version number, then exit
+.SH AUTHOR
+Written by David J. MacKenzie and Paul Eggert.
+.SH "REPORTING BUGS"
+Report bugs to <dickey@invisible\-island.net>.
+.SH COPYRIGHT
+Copyright 1994, 1995, 1999, 2000 Free Software Foundation, Inc.
+.br
+This is free software; see the source for copying conditions. There is NO
+warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+.SH "SEE ALSO"
+.BR autoconf (1),
+.BR autoreconf (1),
+.BR autoupdate (1),
+.BR autoheader (1),
+.BR autoscan (1),
+.BR config.guess (1),
+.BR config.sub (1),
+.BR ifnames (1),
+.BR libtool (1).
+.PP
+The full documentation for
+.B ifnames
+is maintained as a Texinfo manual. If the
+.B info
+and
+.B ifnames
+programs are properly installed at your site, the command
+.IP
+.B info ifnames
+.PP
+should give you access to the complete manual.
diff --git a/man/ifnames.x b/man/ifnames.x
new file mode 100644
index 0000000..214ccce
--- /dev/null
+++ b/man/ifnames.x
@@ -0,0 +1,3 @@
+[name]
+ifnames \- Extract CPP conditionals from a set of files
+