summaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/ac252.spec89
-rw-r--r--package/debian/changelog162
-rw-r--r--package/debian/compat1
-rw-r--r--package/debian/control17
-rw-r--r--package/debian/copyright69
-rw-r--r--package/debian/docs2
-rwxr-xr-xpackage/debian/rules100
-rw-r--r--package/debian/source/format1
-rw-r--r--package/debian/watch4
9 files changed, 445 insertions, 0 deletions
diff --git a/package/ac252.spec b/package/ac252.spec
new file mode 100644
index 0000000..37e5acf
--- /dev/null
+++ b/package/ac252.spec
@@ -0,0 +1,89 @@
+Summary: autoconf-252 - Generate configuration scripts
+%define AppProgram autoconf
+%define AppVersion 2.52
+%define AppRelease 20231210
+%define AppSuffix -252
+# $Id: ac252.spec,v 1.48 2023/12/09 11:52:45 tom Exp $
+Name: ac252
+Version: %{AppVersion}
+Release: %{AppRelease}
+License: GPLv2
+Group: Applications/Development
+URL: http://invisible-island.net/%{AppProgram}
+Source0: http://invisible-island.net/archives/%{AppProgram}/%{AppProgram}-%{AppVersion}-%{AppRelease}.tgz
+
+BuildArch: noarch
+#BuildRequires: m4
+Requires: m4
+
+%description
+This is a stable version of autoconf, used by all of my applications.
+See http://invisible-island.net/autoconf/
+
+%define MyName %{AppProgram}%{AppSuffix}
+
+%define find_tool tool=install-info; for dir in /sbin /usr/sbin; do if test -f $dir/$tool; then tool=$dir/$tool;break;fi;done
+
+%prep
+
+%setup -q -n %{AppProgram}-%{AppVersion}-%{AppRelease}
+
+%build
+
+INSTALL_PROGRAM='${INSTALL}' \
+ ./configure \
+ --program-suffix=%{AppSuffix} \
+ --target %{_target_platform} \
+ --prefix=%{_prefix} \
+ --bindir=%{_bindir} \
+ --libdir=%{_libdir} \
+ --mandir=%{_mandir} \
+ --datadir=%{_datadir}/%{MyName} \
+ --infodir=%{_infodir}
+
+make
+
+%install
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
+
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{_infodir}/dir
+rm -f $RPM_BUILD_ROOT%{_infodir}/standards*
+
+%post
+%{find_tool}
+$tool \
+ %{_infodir}/%{MyName}.info \
+ %{_infodir}/dir || :
+
+%preun
+if [ $1 = 0 ] ; then
+ %{find_tool}
+ $tool \
+ --delete \
+ %{_infodir}/%{MyName}.info \
+ %{_infodir}/dir || :
+fi
+
+%files
+%defattr(-,root,root)
+%{_bindir}/*%{AppSuffix}
+%{_mandir}/man1/*%{AppSuffix}*
+%{_datadir}/%{MyName}*
+%{_infodir}/*%{AppSuffix}*
+
+%changelog
+# each patch should add its ChangeLog entries here
+
+* Sun Sep 03 2023 Thomas E. Dickey
+- update http-url, rpmlint'd
+
+* Sun Aug 19 2018 Thomas E. Dickey
+- update ftp-url
+
+* Fri Oct 01 2010 Thomas E. Dickey
+- adapt rules for installing info file from
+ http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
+
+* Tue Sep 28 2010 Thomas E. Dickey
+- initial version
diff --git a/package/debian/changelog b/package/debian/changelog
new file mode 100644
index 0000000..e045ac8
--- /dev/null
+++ b/package/debian/changelog
@@ -0,0 +1,162 @@
+ac252 (20231210) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 09 Dec 2023 06:52:45 -0500
+
+ac252 (20231203) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Fri, 01 Dec 2023 19:55:55 -0500
+
+ac252 (20230903) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 19 Aug 2023 12:08:43 -0400
+
+ac252 (20230114) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 14 Jan 2023 14:57:24 -0500
+
+ac252 (20221202) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Fri, 02 Dec 2022 19:00:33 -0500
+
+ac252 (20221009) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 09 Oct 2022 15:15:35 -0400
+
+ac252 (20221001) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 01 Oct 2022 10:35:08 -0400
+
+ac252 (20210509) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 09 May 2021 13:53:30 -0400
+
+ac252 (20210105) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Tue, 05 Jan 2021 18:42:28 -0500
+
+ac252 (20210101) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Tue, 29 Dec 2020 13:11:02 -0500
+
+ac252 (20201228) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 27 Dec 2020 09:26:56 -0500
+
+ac252 (20200802) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 02 Aug 2020 13:29:38 -0400
+
+ac252 (20200111) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 11 Jan 2020 10:08:04 -0500
+
+ac252 (20190901) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 01 Sep 2019 13:24:56 -0400
+
+ac252 (20190828) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Wed, 28 Aug 2019 17:02:12 -0400
+
+ac252 (20181006) unstable; urgency=low
+
+ * maintenance updates
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Fri, 05 Oct 2018 04:27:30 -0400
+
+ac252 (20180819) unstable; urgency=low
+
+ * recognize "--runstatedir"
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 19 Aug 2018 11:43:59 -0400
+
+ac252 (20170501) unstable; urgency=low
+
+ * fix "make check" for OSX, also use 'int main(void)', per c89.
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sun, 30 Apr 2017 10:48:44 -0400
+
+ac252 (20150926) unstable; urgency=low
+
+ * workaround multiline substitutions vs splitting of script in config.status
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 26 Sep 2015 17:17:41 -0400
+
+ac252 (20141204) unstable; urgency=low
+
+ * workaround for a broken port of "dash"
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Wed, 03 Dec 2014 20:40:36 -0500
+
+ac252 (20121002) unstable; urgency=low
+
+ * workaround for GCC_PRINTFLIKE in autoheader
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Tue, 02 Oct 2012 05:45:57 -0400
+
+ac252 (20120929) unstable; urgency=low
+
+ * fix regression
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 29 Sep 2012 14:41:32 -0400
+
+ac252 (20120923) unstable; urgency=low
+
+ * improve --datarootdir support
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 22 Sep 2012 11:01:26 -0400
+
+ac252 (20120811) unstable; urgency=low
+
+ * add --datarootdir support
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 11 Aug 2012 16:48:21 -0400
+
+ac252 (20120310) unstable; urgency=low
+
+ * repackaging for consistent versions
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Sat, 10 Mar 2012 20:27:13 -0500
+
+ac252 (20120303) unstable; urgency=low
+
+ * Modify AC_LANG_FUNC_LINK_TRY to work around breakage in Intel compiler's
+ use of linker.
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Tue, 28 Sep 2010 20:11:31 -0400
+
+ac252 (20101002) unstable; urgency=low
+
+ * Add package scripts to upstream source, for test-builds.
+
+ -- Thomas E. Dickey <dickey@invisible-island.net> Tue, 28 Sep 2010 20:11:31 -0400
diff --git a/package/debian/compat b/package/debian/compat
new file mode 100644
index 0000000..f599e28
--- /dev/null
+++ b/package/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/package/debian/control b/package/debian/control
new file mode 100644
index 0000000..3c5c2be
--- /dev/null
+++ b/package/debian/control
@@ -0,0 +1,17 @@
+Source: ac252
+Maintainer: Thomas E. Dickey <dickey@invisible-island.net>
+Section: devel
+Priority: optional
+Standards-Version: 3.8.4
+Build-Depends-Indep: texinfo (>= 4.6), m4 (>= 1.4), help2man
+Build-Depends: debhelper (>= 5)
+Homepage: http://invisible-island.net/autoconf/
+
+Package: ac252
+Architecture: any
+Depends: m4 (>= 1.4.6), ${misc:Depends}
+Description: autoconf 2.52 (stable)
+ This is the supported version of autoconf used for programs developed and
+ maintained by Thomas E. Dickey
+ .
+ See http://invisible-island.net/autoconf/
diff --git a/package/debian/copyright b/package/debian/copyright
new file mode 100644
index 0000000..1fc6bc2
--- /dev/null
+++ b/package/debian/copyright
@@ -0,0 +1,69 @@
+Upstream source http://invisible-island.net/autoconf/autoconf.html
+
+-------------------------------------------------------------------------------
+Copyright 2003-2022,2023 Thomas E. Dickey
+Copyright 2001 Free Software Foundation, Inc.
+
+This program is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 2, or (at your option)
+any later version.
+-------------------------------------------------------------------------------
+
+Files: install-sh
+Copyright: 1994 X Consortium
+Licence: other-BSD
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to
+ deal in the Software without restriction, including without limitation the
+ rights to use, copy, modify, merge, publish, distribute, sublicense, and/or
+ sell copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ X CONSORTIUM BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+ AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNEC-
+ TION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+ Except as contained in this notice, the name of the X Consortium shall not
+ be used in advertising or otherwise to promote the sale, use or other deal-
+ ings in this Software without prior written authorization from the X Consor-
+ tium.
+
+ FSF changes to this file are in the public domain.
+
+ Calling this script install-sh is preferred over install.sh, to prevent
+ `make' implicit rules from creating a file called install from it
+ when there is no Makefile.
+
+ This script is compatible with the BSD install script, but was written
+ from scratch. It can only install one file at a time, a restriction
+ shared with many OS's install programs.
+
+Files: debian/*
+Copyright: 2010-2022,2023 Thomas E. Dickey
+Licence: other-BSD
+ Permission to use, copy, modify, and distribute this software and its
+ documentation for any purpose and without fee is hereby granted,
+ provided that the above copyright notice appear in all copies and that
+ both that copyright notice and this permission notice appear in
+ supporting documentation, and that the name of the above listed
+ copyright holder(s) not be used in advertising or publicity pertaining
+ to distribution of the software without specific, written prior
+ permission.
+
+ THE ABOVE LISTED COPYRIGHT HOLDER(S) DISCLAIM ALL WARRANTIES WITH REGARD
+ TO THIS SOFTWARE, INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY
+ AND FITNESS, IN NO EVENT SHALL THE ABOVE LISTED COPYRIGHT HOLDER(S) BE
+ LIABLE FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in '/usr/share/common-licenses/GPL-2'
diff --git a/package/debian/docs b/package/debian/docs
new file mode 100644
index 0000000..e4cf55f
--- /dev/null
+++ b/package/debian/docs
@@ -0,0 +1,2 @@
+README
+THANKS
diff --git a/package/debian/rules b/package/debian/rules
new file mode 100755
index 0000000..59298b2
--- /dev/null
+++ b/package/debian/rules
@@ -0,0 +1,100 @@
+#!/usr/bin/make -f
+# MAde with the aid of dh_make, by Craig Small
+# Sample debian/rules that uses debhelper. GNU copyright 1997 by Joey Hess.
+# Some lines taken from debmake, by Cristoph Lameter.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+PACKAGE = ac252
+DSTDIR := $(CURDIR)/debian/$(PACKAGE)
+
+CFLAGS =
+
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
+ CFLAGS += -O0
+else
+ CFLAGS += -O2
+endif
+ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
+ INSTALL_PROGRAM += -s
+endif
+
+CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
+CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
+LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
+
+configure: configure-stamp
+configure-stamp:
+ dh_testdir
+
+ CPPFLAGS="$(CPPFLAGS)" \
+ CFLAGS="$(CFLAGS)" \
+ LDFLAGS="$(LDFLAGS)" \
+ ./configure \
+ --program-suffix=-252 \
+ --host=$(DEB_HOST_GNU_TYPE) \
+ --build=$(DEB_BUILD_GNU_TYPE) \
+ --prefix=/usr \
+ --mandir=\$${prefix}/share/man \
+ --infodir=\$${prefix}/share/info \
+ --datadir=\$${prefix}/share/$(PACKAGE)
+
+ touch configure-stamp
+
+build: build-stamp
+build-stamp: configure-stamp
+ dh_testdir
+
+ $(MAKE)
+
+ touch build-stamp
+
+clean:
+ dh_testdir
+ dh_testroot
+
+ [ ! -f Makefile ] || $(MAKE) distclean
+ rm -f build-stamp install-stamp
+
+ dh_clean
+
+install: install-stamp
+install-stamp: build-stamp
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ $(MAKE) install DESTDIR=$(DSTDIR)
+ rm -f $(DSTDIR)/usr/share/info/dir*
+ rm -f $(DSTDIR)/usr/share/info/standard*
+
+ touch install-stamp
+
+# Build architecture-independent files here.
+binary-indep: build install
+# No binary-indep target.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installdocs
+ dh_installchangelogs ChangeLog
+ dh_strip
+ dh_compress
+ dh_fixperms
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install install-stamp
diff --git a/package/debian/source/format b/package/debian/source/format
new file mode 100644
index 0000000..89ae9db
--- /dev/null
+++ b/package/debian/source/format
@@ -0,0 +1 @@
+3.0 (native)
diff --git a/package/debian/watch b/package/debian/watch
new file mode 100644
index 0000000..958d8e1
--- /dev/null
+++ b/package/debian/watch
@@ -0,0 +1,4 @@
+version=3
+
+opts=passive http://invisible-island.net/archives/autoconf/autoconf-2.52-(\d+)\.tgz \
+ debian uupdate