summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 10:13:45 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 10:13:45 +0000
commit7fe5d9fe03501b2f907da85e964ce396568fe7ba (patch)
tree02073c155cdedf2550d2406c56663767165979e2
parentAdding derivative version file for Progress Linux 7.99 (graograman-backports). (diff)
downloadbase-files-7fe5d9fe03501b2f907da85e964ce396568fe7ba.tar.xz
base-files-7fe5d9fe03501b2f907da85e964ce396568fe7ba.zip
Adding dpkg origin file for Progress Linux.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/base-files.install1
-rw-r--r--debian/local/dpkg/progress-linux4
-rw-r--r--debian/postinst.in7
-rwxr-xr-xdebian/rules2
4 files changed, 13 insertions, 1 deletions
diff --git a/debian/base-files.install b/debian/base-files.install
index 46f1ecc..34b22db 100644
--- a/debian/base-files.install
+++ b/debian/base-files.install
@@ -3,3 +3,4 @@ debian/local/base-files/issue.net /etc
debian/local/base-files/motd /usr/share/base-files
debian/local/base-files/os-release /etc
debian/local/base-files/progress-linux_version /etc
+debian/local/dpkg/progress-linux /etc/dpkg/origins
diff --git a/debian/local/dpkg/progress-linux b/debian/local/dpkg/progress-linux
new file mode 100644
index 0000000..d423898
--- /dev/null
+++ b/debian/local/dpkg/progress-linux
@@ -0,0 +1,4 @@
+Vendor: progress-linux
+Vendor-URL: https://progress-linux.org
+Bugs: mailto:maintainers@lists.progress-linux.org
+Parent: Debian
diff --git a/debian/postinst.in b/debian/postinst.in
index 2b31ff3..0ca10b6 100644
--- a/debian/postinst.in
+++ b/debian/postinst.in
@@ -52,6 +52,13 @@ update_to_current_default() {
fi
}
+# remove debian origin default symlink
+if [ -h "$DPKG_ROOT/etc/dpkg/origins/default" ]; then
+ if [ "`readlink "$DPKG_ROOT/etc/dpkg/origins/default"`" = "debian" ]; then
+ rm -f "$DPKG_ROOT/etc/dpkg/origins/default"
+ fi
+fi
+
if [ ! -e "$DPKG_ROOT/etc/dpkg/origins/default" ]; then
if [ -e "$DPKG_ROOT/etc/dpkg/origins/#VENDORFILE#" ]; then
ln -sf #VENDORFILE# "$DPKG_ROOT/etc/dpkg/origins/default"
diff --git a/debian/rules b/debian/rules
index 4c0497b..3b8f84d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,7 @@ ifeq ($(DEB_HOST_GNU_SYSTEM),gnu)
OSNAME=GNU/Hurd
endif
-VENDORFILE = debian
+VENDORFILE = progress-linux
DESTDIR = debian/base-files
%: