summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/NEWS9
-rw-r--r--debian/README7
-rw-r--r--debian/changelog12
-rw-r--r--debian/postinst2
-rwxr-xr-xdebian/rules3
-rw-r--r--debian/timestamps21
6 files changed, 54 insertions, 0 deletions
diff --git a/debian/NEWS b/debian/NEWS
new file mode 100644
index 0000000..285c231
--- /dev/null
+++ b/debian/NEWS
@@ -0,0 +1,9 @@
+base-files (13.2) unstable; urgency=medium
+
+ By default, snippets for Bourne and Bourne-compatible shells (*.sh)
+ in /etc/profile.d will only be sourced by /etc/profile if they
+ conform to a sensible regexp including only some ASCII characters,
+ as it already happens with cron entries and the like. Previously,
+ the behaviour was not really well defined.
+
+ -- Santiago Vila <sanvila@debian.org> Fri, 03 May 2024 18:04:00 +0200
diff --git a/debian/README b/debian/README
index 9ced2ea..9cc76c8 100644
--- a/debian/README
+++ b/debian/README
@@ -95,5 +95,12 @@ freedom to remove those directories without them being created again
when base-files is upgraded. Therefore, if you are running any sort of
compliance tests, you should do it on newly installed systems only.
+Q. My system (when I do "dpkg -s base-files") shows /etc/profile as
+an "obsolete conffile". Is this ok?
+
+A. Yes. The file was handled by base-files as a conffile in the dpkg sense
+in the past, so dpkg may consider the file as an obsolete conffile.
+There is currently not a way to tell dpkg to unregister it as a conffile
+without removing it, so the best approach for now is to do nothing about it.
Santiago Vila <sanvila@debian.org>
diff --git a/debian/changelog b/debian/changelog
index f923d50..cb72d36 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,15 @@
+base-files (13.2) unstable; urgency=medium
+
+ * Document that /etc/profile is not a conffile anymore. Closes: #868095.
+ * Use a regexp to source files in /etc/profile.d. The behaviour should now be
+ well defined and consistent. Closes: #885414, #1069279.
+ * Add NEWS.Debian entry for the above.
+ * Document that the default umask is defined in /etc/login.defs. Closes: #983606.
+ * Add #DEBHELPER# token to postinst to make lintian happy.
+ * Make binary package to be git-reproducible.
+
+ -- Santiago Vila <sanvila@debian.org> Fri, 03 May 2024 18:15:00 +0200
+
base-files (13.1) unstable; urgency=medium
* Rename postinst.in to postinst. Use dh_installdeb token feature instead.
diff --git a/debian/postinst b/debian/postinst
index 2ce18e2..2708d17 100644
--- a/debian/postinst
+++ b/debian/postinst
@@ -107,3 +107,5 @@ if [ "$1" = "configure" ] && [ "$2" != "" ]; then
install_directory mnt 755 root
fi
fi
+
+#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index c7a291d..05dfb39 100755
--- a/debian/rules
+++ b/debian/rules
@@ -14,6 +14,9 @@ DESTDIR = debian/base-files
%:
dh $@
+execute_after_dh_clean:
+ sh debian/timestamps
+
override_dh_auto_build:
sh debian/check-md5sum-etc profile
diff --git a/debian/timestamps b/debian/timestamps
new file mode 100644
index 0000000..1c92569
--- /dev/null
+++ b/debian/timestamps
@@ -0,0 +1,21 @@
+#!/bin/sh
+set -e
+BUILD_DATE=$(dpkg-parsechangelog -S Date)
+touch -d "${BUILD_DATE}" etc/*
+touch -d "${BUILD_DATE}" motd/*
+touch -d "${BUILD_DATE}" origins/*
+touch -d "${BUILD_DATE}" share/*
+touch -d "1996-12-16 02:58:50 UTC" licenses/Artistic
+touch -d "1999-08-26 12:06:20 UTC" licenses/BSD
+touch -d "2004-12-19 20:30:25 UTC" licenses/Apache-2.0
+touch -d "2010-03-23 23:34:05 UTC" licenses/GPL-1
+touch -d "2010-03-23 23:34:05 UTC" licenses/GPL-2
+touch -d "2010-03-23 23:34:05 UTC" licenses/LGPL-2.1
+touch -d "2017-04-03 11:00:00 UTC" licenses/MPL-1.1
+touch -d "2017-04-03 20:00:00 UTC" licenses/MPL-2.0
+touch -d "2017-04-25 22:26:15 UTC" licenses/CC0-1.0
+touch -d "2017-09-30 07:14:21 UTC" licenses/GPL-3
+touch -d "2017-09-30 07:14:21 UTC" licenses/LGPL-3
+touch -d "2017-09-30 07:15:28 UTC" licenses/GFDL-1.2
+touch -d "2022-02-10 06:14:38 UTC" licenses/GFDL-1.3
+touch -d "2022-02-10 06:14:38 UTC" licenses/LGPL-2