summaryrefslogtreecommitdiffstats
path: root/debian/patches/13-backport-support-for-python-9.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/13-backport-support-for-python-9.patch')
-rw-r--r--debian/patches/13-backport-support-for-python-9.patch62
1 files changed, 0 insertions, 62 deletions
diff --git a/debian/patches/13-backport-support-for-python-9.patch b/debian/patches/13-backport-support-for-python-9.patch
deleted file mode 100644
index de75f45..0000000
--- a/debian/patches/13-backport-support-for-python-9.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-commit dc1c404b3c14cd3e3627a6720cf32a4e27079285
-Author: Ville Skyttä <ville.skytta@iki.fi>
-Date: Sun Sep 6 22:57:28 2020 +0300
-
- python, pyvenv: install for 3.9
-
-diff --git a/completions/Makefile.am b/completions/Makefile.am
-index e43d0e3c..ba75fa48 100644
---- a/completions/Makefile.am
-+++ b/completions/Makefile.am
-@@ -677,11 +677,13 @@ CLEANFILES = \
- python3.6 \
- python3.7 \
- python3.8 \
-+ python3.9 \
- pyvenv-3.4 \
- pyvenv-3.5 \
- pyvenv-3.6 \
- pyvenv-3.7 \
- pyvenv-3.8 \
-+ pyvenv-3.9 \
- qemu-kvm \
- qemu-system-i386 \
- qemu-system-x86_64 \
-@@ -894,9 +896,11 @@ symlinks: $(DATA)
- $(ss) pylint \
- pylint-2 pylint-3
- $(ss) python \
-- micropython pypy pypy3 python2 python2.7 python3 python3.3 python3.4 python3.5 python3.6 python3.7 python3.8
-+ micropython pypy pypy3 python2 python2.7 python3 python3.3 \
-+ python3.4 python3.5 python3.6 python3.7 python3.8 python3.9
- $(ss) pyvenv \
-- pyvenv-3.4 pyvenv-3.5 pyvenv-3.6 pyvenv-3.7 pyvenv-3.8
-+ pyvenv-3.4 pyvenv-3.5 pyvenv-3.6 pyvenv-3.7 pyvenv-3.8 \
-+ pyvenv-3.9
- $(ss) qdbus \
- dcop
- $(ss) qemu \
-diff --git a/completions/python b/completions/python
-index d50c18f0..d7e18b90 100644
---- a/completions/python
-+++ b/completions/python
-@@ -62,6 +62,6 @@ _python()
- COMPREPLY=($(compgen -W '$(_parse_help "$1" -h)' -- "$cur"))
- fi
- } &&
-- complete -F _python python python2 python2.7 python3 python3.{3..8} pypy pypy3 micropython
-+ complete -F _python python python2 python2.7 python3 python3.{3..9} pypy pypy3 micropython
-
- # ex: filetype=sh
-diff --git a/completions/pyvenv b/completions/pyvenv
-index 527a3840..3a1ecb37 100644
---- a/completions/pyvenv
-+++ b/completions/pyvenv
-@@ -20,6 +20,6 @@ _pyvenv()
-
- _filedir -d
- } &&
-- complete -F _pyvenv pyvenv pyvenv-3.{4..8}
-+ complete -F _pyvenv pyvenv pyvenv-3.{4..9}
-
- # ex: filetype=sh