summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml8
1 files changed, 3 insertions, 5 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 83d0112..12d45e6 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,7 +1,7 @@
[tool.ruff]
line-length = 79
target-version = "py37"
-lint.select = ["E", "F", "B"]
+lint.select = ["E", "F", "B", "I"]
lint.ignore = [
# https://docs.astral.sh/ruff/formatter/#conflicting-lint-rules
# (keep order of ignores here same as ^there for maintainability)
@@ -21,8 +21,6 @@ lint.ignore = [
"ISC002",
"E501",
]
+lint.isort.known-first-party = ["conftest"]
+lint.isort.known-third-party = ["pexpect", "pytest"]
fix = true
-
-[tool.ruff.lint.isort]
-known-first-party = ["conftest"]
-known-third-party = ["pexpect", "pytest"]