summaryrefslogtreecommitdiffstats
path: root/tests/testsuite/init/formats_source
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /tests/testsuite/init/formats_source
parentInitial commit. (diff)
downloadcargo-upstream.tar.xz
cargo-upstream.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/testsuite/init/formats_source')
-rw-r--r--tests/testsuite/init/formats_source/in/rustfmt.toml1
-rw-r--r--tests/testsuite/init/formats_source/mod.rs29
-rw-r--r--tests/testsuite/init/formats_source/out/Cargo.toml8
-rw-r--r--tests/testsuite/init/formats_source/out/rustfmt.toml1
-rw-r--r--tests/testsuite/init/formats_source/out/src/lib.rs14
-rw-r--r--tests/testsuite/init/formats_source/stderr.log1
-rw-r--r--tests/testsuite/init/formats_source/stdout.log0
7 files changed, 54 insertions, 0 deletions
diff --git a/tests/testsuite/init/formats_source/in/rustfmt.toml b/tests/testsuite/init/formats_source/in/rustfmt.toml
new file mode 100644
index 0000000..b196eaa
--- /dev/null
+++ b/tests/testsuite/init/formats_source/in/rustfmt.toml
@@ -0,0 +1 @@
+tab_spaces = 2
diff --git a/tests/testsuite/init/formats_source/mod.rs b/tests/testsuite/init/formats_source/mod.rs
new file mode 100644
index 0000000..ac1fb62
--- /dev/null
+++ b/tests/testsuite/init/formats_source/mod.rs
@@ -0,0 +1,29 @@
+use cargo_test_support::compare::assert_ui;
+use cargo_test_support::prelude::*;
+use cargo_test_support::{process, Project};
+
+use cargo_test_support::curr_dir;
+
+#[cargo_test]
+fn case() {
+ // This cannot use `requires_rustfmt` because rustfmt is not available in
+ // the rust-lang/rust environment. Additionally, if running cargo without
+ // rustup (but with rustup installed), this test also fails due to HOME
+ // preventing the proxy from choosing a toolchain.
+ if let Err(e) = process("rustfmt").arg("-V").exec_with_output() {
+ eprintln!("skipping test, rustfmt not available:\n{e:?}");
+ return;
+ }
+ let project = Project::from_template(curr_dir!().join("in"));
+ let project_root = &project.root();
+
+ snapbox::cmd::Command::cargo_ui()
+ .arg_line("init --lib --vcs none")
+ .current_dir(project_root)
+ .assert()
+ .success()
+ .stdout_matches_path(curr_dir!().join("stdout.log"))
+ .stderr_matches_path(curr_dir!().join("stderr.log"));
+
+ assert_ui().subset_matches(curr_dir!().join("out"), project_root);
+}
diff --git a/tests/testsuite/init/formats_source/out/Cargo.toml b/tests/testsuite/init/formats_source/out/Cargo.toml
new file mode 100644
index 0000000..dcdb8da
--- /dev/null
+++ b/tests/testsuite/init/formats_source/out/Cargo.toml
@@ -0,0 +1,8 @@
+[package]
+name = "case"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
diff --git a/tests/testsuite/init/formats_source/out/rustfmt.toml b/tests/testsuite/init/formats_source/out/rustfmt.toml
new file mode 100644
index 0000000..b196eaa
--- /dev/null
+++ b/tests/testsuite/init/formats_source/out/rustfmt.toml
@@ -0,0 +1 @@
+tab_spaces = 2
diff --git a/tests/testsuite/init/formats_source/out/src/lib.rs b/tests/testsuite/init/formats_source/out/src/lib.rs
new file mode 100644
index 0000000..3b9acff
--- /dev/null
+++ b/tests/testsuite/init/formats_source/out/src/lib.rs
@@ -0,0 +1,14 @@
+pub fn add(left: usize, right: usize) -> usize {
+ left + right
+}
+
+#[cfg(test)]
+mod tests {
+ use super::*;
+
+ #[test]
+ fn it_works() {
+ let result = add(2, 2);
+ assert_eq!(result, 4);
+ }
+}
diff --git a/tests/testsuite/init/formats_source/stderr.log b/tests/testsuite/init/formats_source/stderr.log
new file mode 100644
index 0000000..f459bf2
--- /dev/null
+++ b/tests/testsuite/init/formats_source/stderr.log
@@ -0,0 +1 @@
+ Created library package
diff --git a/tests/testsuite/init/formats_source/stdout.log b/tests/testsuite/init/formats_source/stdout.log
new file mode 100644
index 0000000..e69de29
--- /dev/null
+++ b/tests/testsuite/init/formats_source/stdout.log