summaryrefslogtreecommitdiffstats
path: root/tests/testsuite/timings.rs
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /tests/testsuite/timings.rs
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/testsuite/timings.rs')
-rw-r--r--tests/testsuite/timings.rs53
1 files changed, 53 insertions, 0 deletions
diff --git a/tests/testsuite/timings.rs b/tests/testsuite/timings.rs
new file mode 100644
index 0000000..8f06ac6
--- /dev/null
+++ b/tests/testsuite/timings.rs
@@ -0,0 +1,53 @@
+//! Tests for --timings.
+
+use cargo_test_support::project;
+use cargo_test_support::registry::Package;
+
+#[cargo_test]
+fn timings_works() {
+ Package::new("dep", "0.1.0").publish();
+
+ let p = project()
+ .file(
+ "Cargo.toml",
+ r#"
+ [package]
+ name = "foo"
+ version = "0.1.0"
+
+ [dependencies]
+ dep = "0.1"
+ "#,
+ )
+ .file("src/lib.rs", "")
+ .file("src/main.rs", "fn main() {}")
+ .file("tests/t1.rs", "")
+ .file("examples/ex1.rs", "fn main() {}")
+ .build();
+
+ p.cargo("build --all-targets --timings")
+ .with_stderr_unordered(
+ "\
+[UPDATING] [..]
+[DOWNLOADING] crates ...
+[DOWNLOADED] dep v0.1.0 [..]
+[COMPILING] dep v0.1.0
+[COMPILING] foo v0.1.0 [..]
+[FINISHED] [..]
+ Timing report saved to [..]/foo/target/cargo-timings/cargo-timing-[..].html
+",
+ )
+ .run();
+
+ p.cargo("clean").run();
+
+ p.cargo("test --timings").run();
+
+ p.cargo("clean").run();
+
+ p.cargo("check --timings").run();
+
+ p.cargo("clean").run();
+
+ p.cargo("doc --timings").run();
+}