summaryrefslogtreecommitdiffstats
path: root/vendor/der/debian/patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/der/debian/patches
parentInitial commit. (diff)
downloadcargo-upstream.tar.xz
cargo-upstream.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/der/debian/patches')
-rw-r--r--vendor/der/debian/patches/fix-tests-feature-time.diff25
-rw-r--r--vendor/der/debian/patches/relax-dep.diff22
-rw-r--r--vendor/der/debian/patches/series2
3 files changed, 49 insertions, 0 deletions
diff --git a/vendor/der/debian/patches/fix-tests-feature-time.diff b/vendor/der/debian/patches/fix-tests-feature-time.diff
new file mode 100644
index 0000000..d780563
--- /dev/null
+++ b/vendor/der/debian/patches/fix-tests-feature-time.diff
@@ -0,0 +1,25 @@
+Description: fix 'time' feature tests
+ The following invocation fails due to Error not being in scope:
+ cargo test --all-targets --no-default-features --features time
+
+Author: Emanuele Rocca <ema@debian.org>
+
+Last-Update: 2023-06-30
+Index: der/src/asn1/generalized_time.rs
+===================================================================
+--- der.orig/src/asn1/generalized_time.rs
++++ der/src/asn1/generalized_time.rs
+@@ -8,9 +8,12 @@ use crate::{
+ };
+ use core::time::Duration;
+
++#[cfg(any(feature = "std", feature = "time"))]
++use crate::Error;
++
+ #[cfg(feature = "std")]
+ use {
+- crate::{asn1::AnyRef, Error},
++ crate::asn1::AnyRef,
+ std::time::SystemTime,
+ };
+
diff --git a/vendor/der/debian/patches/relax-dep.diff b/vendor/der/debian/patches/relax-dep.diff
new file mode 100644
index 0000000..d774244
--- /dev/null
+++ b/vendor/der/debian/patches/relax-dep.diff
@@ -0,0 +1,22 @@
+Index: der/Cargo.toml
+===================================================================
+--- der.orig/Cargo.toml
++++ der/Cargo.toml
+@@ -45,7 +45,7 @@ rustdoc-args = [
+ ]
+
+ [dependencies.arbitrary]
+-version = "1.3"
++version = "1.0"
+ features = ["derive"]
+ optional = true
+
+@@ -77,7 +77,7 @@ optional = true
+ default-features = false
+
+ [dev-dependencies.hex-literal]
+-version = "0.4.1"
++version = "0.3.0"
+
+ [dev-dependencies.proptest]
+ version = "1"
diff --git a/vendor/der/debian/patches/series b/vendor/der/debian/patches/series
new file mode 100644
index 0000000..21d6659
--- /dev/null
+++ b/vendor/der/debian/patches/series
@@ -0,0 +1,2 @@
+relax-dep.diff
+fix-tests-feature-time.diff