summaryrefslogtreecommitdiffstats
path: root/vendor/flate2/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/flate2/Cargo.toml
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/flate2/Cargo.toml')
-rw-r--r--vendor/flate2/Cargo.toml91
1 files changed, 91 insertions, 0 deletions
diff --git a/vendor/flate2/Cargo.toml b/vendor/flate2/Cargo.toml
new file mode 100644
index 0000000..23bc502
--- /dev/null
+++ b/vendor/flate2/Cargo.toml
@@ -0,0 +1,91 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "flate2"
+version = "1.0.28"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Josh Triplett <josh@joshtriplett.org>",
+]
+description = """
+DEFLATE compression and decompression exposed as Read/BufRead/Write streams.
+Supports miniz_oxide and multiple zlib implementations. Supports zlib, gzip,
+and raw deflate streams.
+"""
+homepage = "https://github.com/rust-lang/flate2-rs"
+documentation = "https://docs.rs/flate2"
+readme = "README.md"
+keywords = [
+ "gzip",
+ "deflate",
+ "zlib",
+ "zlib-ng",
+ "encoding",
+]
+categories = [
+ "compression",
+ "api-bindings",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/flate2-rs"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.crc32fast]
+version = "1.2.0"
+
+[dependencies.libz-sys]
+version = "1.1.8"
+optional = true
+default-features = false
+
+[dependencies.miniz_oxide]
+version = "0.7.1"
+features = ["with-alloc"]
+optional = true
+default-features = false
+
+[dev-dependencies.quickcheck]
+version = "1.0"
+default-features = false
+
+[dev-dependencies.rand]
+version = "0.8"
+
+[features]
+any_impl = []
+any_zlib = ["any_impl"]
+default = ["rust_backend"]
+miniz-sys = ["rust_backend"]
+rust_backend = [
+ "miniz_oxide",
+ "any_impl",
+]
+zlib = [
+ "any_zlib",
+ "libz-sys",
+]
+zlib-default = [
+ "any_zlib",
+ "libz-sys/default",
+]
+
+[target."cfg(all(target_arch = \"wasm32\", not(target_os = \"emscripten\")))".dependencies.miniz_oxide]
+version = "0.7.1"
+features = ["with-alloc"]
+default-features = false