summaryrefslogtreecommitdiffstats
path: root/vendor/git2/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/git2/debian
parentInitial commit. (diff)
downloadcargo-upstream.tar.xz
cargo-upstream.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/git2/debian')
-rw-r--r--vendor/git2/debian/patches/disable-vendor.patch14
-rw-r--r--vendor/git2/debian/patches/remove-zlib-ng-compat.patch10
-rw-r--r--vendor/git2/debian/patches/series3
-rw-r--r--vendor/git2/debian/patches/skip-credential_helper5-if-no-git.patch15
4 files changed, 42 insertions, 0 deletions
diff --git a/vendor/git2/debian/patches/disable-vendor.patch b/vendor/git2/debian/patches/disable-vendor.patch
new file mode 100644
index 0000000..a4899d8
--- /dev/null
+++ b/vendor/git2/debian/patches/disable-vendor.patch
@@ -0,0 +1,14 @@
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -70,11 +70,6 @@
+ ssh = ["libgit2-sys/ssh"]
+ ssh_key_from_memory = ["libgit2-sys/ssh_key_from_memory"]
+ unstable = []
+-vendored-libgit2 = ["libgit2-sys/vendored"]
+-vendored-openssl = [
+- "openssl-sys/vendored",
+- "libgit2-sys/vendored-openssl",
+-]
+ zlib-ng-compat = ["libgit2-sys/zlib-ng-compat"]
+
+ [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
diff --git a/vendor/git2/debian/patches/remove-zlib-ng-compat.patch b/vendor/git2/debian/patches/remove-zlib-ng-compat.patch
new file mode 100644
index 0000000..1ac449c
--- /dev/null
+++ b/vendor/git2/debian/patches/remove-zlib-ng-compat.patch
@@ -0,0 +1,10 @@
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -70,7 +70,6 @@
+ ssh = ["libgit2-sys/ssh"]
+ ssh_key_from_memory = ["libgit2-sys/ssh_key_from_memory"]
+ unstable = []
+-zlib-ng-compat = ["libgit2-sys/zlib-ng-compat"]
+
+ [target."cfg(all(unix, not(target_os = \"macos\")))".dependencies.openssl-probe]
+ version = "0.1"
diff --git a/vendor/git2/debian/patches/series b/vendor/git2/debian/patches/series
new file mode 100644
index 0000000..5e0e458
--- /dev/null
+++ b/vendor/git2/debian/patches/series
@@ -0,0 +1,3 @@
+disable-vendor.patch
+remove-zlib-ng-compat.patch
+skip-credential_helper5-if-no-git.patch
diff --git a/vendor/git2/debian/patches/skip-credential_helper5-if-no-git.patch b/vendor/git2/debian/patches/skip-credential_helper5-if-no-git.patch
new file mode 100644
index 0000000..e568602
--- /dev/null
+++ b/vendor/git2/debian/patches/skip-credential_helper5-if-no-git.patch
@@ -0,0 +1,15 @@
+Skip the "credential_helper5" test if git is not installled.
+Index: git2/src/cred.rs
+===================================================================
+--- git2.orig/src/cred.rs
++++ git2/src/cred.rs
+@@ -563,6 +563,9 @@ echo username=c
+
+ #[test]
+ fn credential_helper5() {
++ if !Path::new("/usr/bin/git").exists() {
++ return;
++ } //this test does not work if git is not installed
+ if cfg!(windows) {
+ return;
+ } // shell scripts don't work on Windows