summaryrefslogtreecommitdiffstats
path: root/vendor/idna/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/idna/Cargo.toml
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/idna/Cargo.toml')
-rw-r--r--vendor/idna/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/vendor/idna/Cargo.toml b/vendor/idna/Cargo.toml
new file mode 100644
index 0000000..8286796
--- /dev/null
+++ b/vendor/idna/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.51"
+name = "idna"
+version = "0.4.0"
+authors = ["The rust-url developers"]
+autotests = false
+description = "IDNA (Internationalizing Domain Names in Applications) and Punycode."
+categories = ["no_std"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/servo/rust-url/"
+
+[lib]
+doctest = false
+
+[[test]]
+name = "unit"
+
+[[bench]]
+name = "all"
+harness = false
+
+[dependencies.unicode-bidi]
+version = "0.3.10"
+features = ["hardcoded-data"]
+default-features = false
+
+[dependencies.unicode-normalization]
+version = "0.1.22"
+default-features = false
+
+[dev-dependencies.assert_matches]
+version = "1.3"
+
+[dev-dependencies.bencher]
+version = "0.1"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+alloc = []
+default = ["std"]
+std = [
+ "alloc",
+ "unicode-bidi/std",
+ "unicode-normalization/std",
+]