summaryrefslogtreecommitdiffstats
path: root/vendor/libssh2-sys/debian
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/libssh2-sys/debian
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/libssh2-sys/debian')
-rw-r--r--vendor/libssh2-sys/debian/patches/disable-vendored.patch10
-rw-r--r--vendor/libssh2-sys/debian/patches/no-special-snowflake-env.patch20
-rw-r--r--vendor/libssh2-sys/debian/patches/remove-zlib-ng-compat.patch20
-rw-r--r--vendor/libssh2-sys/debian/patches/series3
4 files changed, 53 insertions, 0 deletions
diff --git a/vendor/libssh2-sys/debian/patches/disable-vendored.patch b/vendor/libssh2-sys/debian/patches/disable-vendored.patch
new file mode 100644
index 0000000..b4fa297
--- /dev/null
+++ b/vendor/libssh2-sys/debian/patches/disable-vendored.patch
@@ -0,0 +1,10 @@
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -39,7 +39,6 @@
+
+ [features]
+ openssl-on-win32 = ["openssl-sys"]
+-vendored-openssl = ["openssl-sys/vendored"]
+ zlib-ng-compat = ["libz-sys/zlib-ng"]
+ [target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+ version = "0.2"
diff --git a/vendor/libssh2-sys/debian/patches/no-special-snowflake-env.patch b/vendor/libssh2-sys/debian/patches/no-special-snowflake-env.patch
new file mode 100644
index 0000000..539d70d
--- /dev/null
+++ b/vendor/libssh2-sys/debian/patches/no-special-snowflake-env.patch
@@ -0,0 +1,20 @@
+--- a/build.rs
++++ b/build.rs
+@@ -20,7 +20,7 @@
+ // can lead to having two copies of libssl loaded at once.
+ // See https://github.com/alexcrichton/ssh2-rs/pull/88
+ println!("cargo:rerun-if-env-changed=LIBSSH2_SYS_USE_PKG_CONFIG");
+- if env::var("LIBSSH2_SYS_USE_PKG_CONFIG").is_ok() {
++ if true {
+ if zlib_ng_compat {
+ panic!("LIBSSH2_SYS_USE_PKG_CONFIG set, but cannot use zlib-ng-compat with system libssh2");
+ }
+@@ -32,7 +32,7 @@
+ }
+ }
+
+- if !Path::new("libssh2/.git").exists() {
++ if false {
+ let _ = Command::new("git")
+ .args(&["submodule", "update", "--init"])
+ .status();
diff --git a/vendor/libssh2-sys/debian/patches/remove-zlib-ng-compat.patch b/vendor/libssh2-sys/debian/patches/remove-zlib-ng-compat.patch
new file mode 100644
index 0000000..e965696
--- /dev/null
+++ b/vendor/libssh2-sys/debian/patches/remove-zlib-ng-compat.patch
@@ -0,0 +1,20 @@
+Index: libssh2-sys/Cargo.toml
+===================================================================
+--- libssh2-sys.orig/Cargo.toml
++++ libssh2-sys/Cargo.toml
+@@ -43,15 +43,9 @@ version = "1.0.25"
+ version = "0.3.11"
+
+ [features]
+-openssl-on-win32 = ["openssl-sys"]
+-zlib-ng-compat = ["libz-sys/zlib-ng"]
+
+ [target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+ version = "0.2"
+
+ [target."cfg(unix)".dependencies.openssl-sys]
+ version = "0.9.35"
+-
+-[target."cfg(windows)".dependencies.openssl-sys]
+-version = "0.9.35"
+-optional = true
diff --git a/vendor/libssh2-sys/debian/patches/series b/vendor/libssh2-sys/debian/patches/series
new file mode 100644
index 0000000..1b75339
--- /dev/null
+++ b/vendor/libssh2-sys/debian/patches/series
@@ -0,0 +1,3 @@
+disable-vendored.patch
+no-special-snowflake-env.patch
+remove-zlib-ng-compat.patch