summaryrefslogtreecommitdiffstats
path: root/vendor/p384/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/p384/Cargo.toml
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/p384/Cargo.toml')
-rw-r--r--vendor/p384/Cargo.toml169
1 files changed, 169 insertions, 0 deletions
diff --git a/vendor/p384/Cargo.toml b/vendor/p384/Cargo.toml
new file mode 100644
index 0000000..d7476a9
--- /dev/null
+++ b/vendor/p384/Cargo.toml
@@ -0,0 +1,169 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "p384"
+version = "0.13.0"
+authors = [
+ "RustCrypto Developers",
+ "Frank Denis <github@pureftpd.org>",
+]
+description = """
+Pure Rust implementation of the NIST P-384 (a.k.a. secp384r1) elliptic curve
+as defined in SP 800-186 with support for ECDH, ECDSA signing/verification,
+and general purpose curve arithmetic support.
+"""
+documentation = "https://docs.rs/p384"
+readme = "README.md"
+keywords = [
+ "crypto",
+ "ecc",
+ "nist",
+ "secp384r1",
+]
+categories = [
+ "cryptography",
+ "no-std",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/elliptic-curves/tree/master/p384"
+autobenches = false
+
+[package.metadata.docs.rs]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.ecdsa-core]
+version = "0.16"
+features = ["der"]
+optional = true
+default-features = false
+package = "ecdsa"
+
+[dependencies.elliptic-curve]
+version = "0.13"
+features = [
+ "hazmat",
+ "sec1",
+]
+default-features = false
+
+[dependencies.hex-literal]
+version = "0.4"
+optional = true
+
+[dependencies.primeorder]
+version = "0.13"
+
+[dependencies.serdect]
+version = "0.2"
+optional = true
+default-features = false
+
+[dependencies.sha2]
+version = "0.10"
+optional = true
+default-features = false
+
+[dev-dependencies.blobby]
+version = "0.3"
+
+[dev-dependencies.criterion]
+version = "0.5"
+
+[dev-dependencies.ecdsa-core]
+version = "0.16"
+features = ["dev"]
+default-features = false
+package = "ecdsa"
+
+[dev-dependencies.hex-literal]
+version = "0.4"
+
+[dev-dependencies.proptest]
+version = "1.0"
+
+[dev-dependencies.rand_core]
+version = "0.6"
+features = ["getrandom"]
+
+[features]
+alloc = [
+ "ecdsa-core?/alloc",
+ "elliptic-curve/alloc",
+]
+arithmetic = [
+ "elliptic-curve/arithmetic",
+ "elliptic-curve/digest",
+]
+bits = [
+ "arithmetic",
+ "elliptic-curve/bits",
+]
+default = [
+ "arithmetic",
+ "ecdh",
+ "ecdsa",
+ "pem",
+ "std",
+]
+digest = [
+ "ecdsa-core/digest",
+ "ecdsa-core/hazmat",
+]
+ecdh = [
+ "arithmetic",
+ "elliptic-curve/ecdh",
+]
+ecdsa = [
+ "arithmetic",
+ "ecdsa-core/signing",
+ "ecdsa-core/verifying",
+ "sha384",
+]
+expose-field = ["arithmetic"]
+hash2curve = [
+ "arithmetic",
+ "elliptic-curve/hash2curve",
+]
+jwk = ["elliptic-curve/jwk"]
+pem = [
+ "elliptic-curve/pem",
+ "ecdsa-core/pem",
+ "pkcs8",
+]
+pkcs8 = [
+ "ecdsa-core/pkcs8",
+ "elliptic-curve/pkcs8",
+]
+serde = [
+ "ecdsa-core/serde",
+ "elliptic-curve/serde",
+ "serdect",
+]
+sha384 = [
+ "digest",
+ "sha2",
+]
+std = [
+ "alloc",
+ "ecdsa-core?/std",
+ "elliptic-curve/std",
+]
+test-vectors = ["hex-literal"]
+voprf = [
+ "elliptic-curve/voprf",
+ "sha2",
+]