summaryrefslogtreecommitdiffstats
path: root/vendor/rustfix/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/rustfix/Cargo.toml
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rustfix/Cargo.toml')
-rw-r--r--vendor/rustfix/Cargo.toml60
1 files changed, 60 insertions, 0 deletions
diff --git a/vendor/rustfix/Cargo.toml b/vendor/rustfix/Cargo.toml
new file mode 100644
index 0000000..782dc7b
--- /dev/null
+++ b/vendor/rustfix/Cargo.toml
@@ -0,0 +1,60 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "rustfix"
+version = "0.6.1"
+authors = [
+ "Pascal Hertleif <killercup@gmail.com>",
+ "Oliver Schneider <oli-obk@users.noreply.github.com>",
+]
+exclude = [
+ "etc/*",
+ "examples/*",
+ "tests/*",
+]
+description = "Automatically apply the suggestions made by rustc"
+documentation = "https://docs.rs/rustfix"
+readme = "Readme.md"
+license = "Apache-2.0/MIT"
+repository = "https://github.com/rust-lang-nursery/rustfix"
+
+[dependencies.anyhow]
+version = "1.0.6"
+
+[dependencies.log]
+version = "0.4.1"
+
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.duct]
+version = "0.9"
+
+[dev-dependencies.env_logger]
+version = "0.5.0-rc.1"
+
+[dev-dependencies.log]
+version = "0.4.1"
+
+[dev-dependencies.proptest]
+version = "0.7.0"
+
+[dev-dependencies.similar]
+version = "0.4.0"
+
+[dev-dependencies.tempfile]
+version = "3"