summaryrefslogtreecommitdiffstats
path: root/vendor/rustix/debian/patches/drop-alloc.diff
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/rustix/debian/patches/drop-alloc.diff
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/rustix/debian/patches/drop-alloc.diff')
-rw-r--r--vendor/rustix/debian/patches/drop-alloc.diff23
1 files changed, 23 insertions, 0 deletions
diff --git a/vendor/rustix/debian/patches/drop-alloc.diff b/vendor/rustix/debian/patches/drop-alloc.diff
new file mode 100644
index 0000000..db3724b
--- /dev/null
+++ b/vendor/rustix/debian/patches/drop-alloc.diff
@@ -0,0 +1,23 @@
+Description: Drop alloc since rustc-std-worspace-alloc-dev isn't packaged
+Author: John Goerzen <jgoerzen@complete.org>
+Last-Update: 2023-10-08 by Peter Michael Green
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+Index: rustix/Cargo.toml
+===================================================================
+--- rustix.orig/Cargo.toml
++++ rustix/Cargo.toml
+@@ -75,5 +75,0 @@ targets = [
+-[dependencies.alloc]
+-version = "1.0.0"
+-optional = true
+-package = "rustc-std-workspace-alloc"
+-
+@@ -174,7 +169,6 @@ rand = []
+ runtime = ["linux-raw-sys/prctl"]
+ rustc-dep-of-std = [
+ "dep:core",
+- "dep:alloc",
+ "dep:compiler_builtins",
+ "linux-raw-sys/rustc-dep-of-std",
+ "bitflags/rustc-dep-of-std",