summaryrefslogtreecommitdiffstats
path: root/vendor/vte/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/vte/Cargo.toml
parentInitial commit. (diff)
downloadcargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.tar.xz
cargo-2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/vte/Cargo.toml')
-rw-r--r--vendor/vte/Cargo.toml39
1 files changed, 39 insertions, 0 deletions
diff --git a/vendor/vte/Cargo.toml b/vendor/vte/Cargo.toml
new file mode 100644
index 0000000..42b45f3
--- /dev/null
+++ b/vendor/vte/Cargo.toml
@@ -0,0 +1,39 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "vte"
+version = "0.10.1"
+authors = ["Joe Wilm <joe@jwilm.com>", "Christian Duerr <contact@christianduerr.com>"]
+exclude = ["/.travis.yml"]
+description = "Parser for implementing terminal emulators"
+documentation = "https://docs.rs/vte/"
+readme = "README.md"
+keywords = ["ansi", "vte", "parser", "terminal"]
+categories = ["parsing", "no-std"]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/alacritty/vte"
+[dependencies.arrayvec]
+version = "0.5.1"
+optional = true
+default-features = false
+
+[dependencies.utf8parse]
+version = "0.2.0"
+
+[dependencies.vte_generate_state_changes]
+version = "0.1.0"
+
+[features]
+default = ["no_std"]
+no_std = ["arrayvec"]