summaryrefslogtreecommitdiffstats
path: root/vendor/winapi-x86_64-pc-windows-gnu
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-04 12:47:55 +0000
commit2aadc03ef15cb5ca5cc2af8a7c08e070742f0ac4 (patch)
tree033cc839730fda84ff08db877037977be94e5e3a /vendor/winapi-x86_64-pc-windows-gnu
parentInitial commit. (diff)
downloadcargo-upstream.tar.xz
cargo-upstream.zip
Adding upstream version 0.70.1+ds1.upstream/0.70.1+ds1upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'vendor/winapi-x86_64-pc-windows-gnu')
-rw-r--r--vendor/winapi-x86_64-pc-windows-gnu/.cargo-checksum.json1
-rw-r--r--vendor/winapi-x86_64-pc-windows-gnu/Cargo.toml22
-rw-r--r--vendor/winapi-x86_64-pc-windows-gnu/build.rs18
-rw-r--r--vendor/winapi-x86_64-pc-windows-gnu/src/lib.rs7
4 files changed, 48 insertions, 0 deletions
diff --git a/vendor/winapi-x86_64-pc-windows-gnu/.cargo-checksum.json b/vendor/winapi-x86_64-pc-windows-gnu/.cargo-checksum.json
new file mode 100644
index 0000000..030fa95
--- /dev/null
+++ b/vendor/winapi-x86_64-pc-windows-gnu/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{},"package":"712e227841d057c1ee1cd2fb22fa7e5a5461ae8e48fa2ca79ec42cfc1931183f"} \ No newline at end of file
diff --git a/vendor/winapi-x86_64-pc-windows-gnu/Cargo.toml b/vendor/winapi-x86_64-pc-windows-gnu/Cargo.toml
new file mode 100644
index 0000000..7e1341b
--- /dev/null
+++ b/vendor/winapi-x86_64-pc-windows-gnu/Cargo.toml
@@ -0,0 +1,22 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "winapi-x86_64-pc-windows-gnu"
+version = "0.4.0"
+authors = ["Peter Atashian <retep998@gmail.com>"]
+build = "build.rs"
+include = ["src/*", "lib/*", "Cargo.toml", "build.rs"]
+description = "Import libraries for the x86_64-pc-windows-gnu target. Please don't use this crate directly, depend on winapi instead."
+keywords = ["windows"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/retep998/winapi-rs"
diff --git a/vendor/winapi-x86_64-pc-windows-gnu/build.rs b/vendor/winapi-x86_64-pc-windows-gnu/build.rs
new file mode 100644
index 0000000..a655b7c
--- /dev/null
+++ b/vendor/winapi-x86_64-pc-windows-gnu/build.rs
@@ -0,0 +1,18 @@
+// Copyright © 2016-2018 winapi-rs developers
+// Licensed under the Apache License, Version 2.0
+// <LICENSE-APACHE or http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your option.
+// All files in the project carrying such notice may not be copied, modified, or distributed
+// except according to those terms.
+fn main() {
+ use std::env::var;
+ use std::path::Path;
+ println!("cargo:rerun-if-env-changed=WINAPI_NO_BUNDLED_LIBRARIES");
+ if var("WINAPI_NO_BUNDLED_LIBRARIES").is_ok() {
+ return;
+ }
+ if var("TARGET").map(|target| target == "x86_64-pc-windows-gnu").unwrap_or(false) {
+ let dir = var("CARGO_MANIFEST_DIR").unwrap();
+ println!("cargo:rustc-link-search=native={}", Path::new(&dir).join("lib").display());
+ }
+}
diff --git a/vendor/winapi-x86_64-pc-windows-gnu/src/lib.rs b/vendor/winapi-x86_64-pc-windows-gnu/src/lib.rs
new file mode 100644
index 0000000..3b7f827
--- /dev/null
+++ b/vendor/winapi-x86_64-pc-windows-gnu/src/lib.rs
@@ -0,0 +1,7 @@
+// Copyright © 2016 winapi-rs developers
+// Licensed under the Apache License, Version 2.0
+// <LICENSE-APACHE or http://www.apache.org/licenses/LICENSE-2.0> or the MIT license
+// <LICENSE-MIT or http://opensource.org/licenses/MIT>, at your option.
+// All files in the project carrying such notice may not be copied, modified, or distributed
+// except according to those terms.
+#![no_std]