summaryrefslogtreecommitdiffstats
path: root/src/etc/man/cargo-uninstall.1
diff options
context:
space:
mode:
Diffstat (limited to 'src/etc/man/cargo-uninstall.1')
-rw-r--r--src/etc/man/cargo-uninstall.1160
1 files changed, 160 insertions, 0 deletions
diff --git a/src/etc/man/cargo-uninstall.1 b/src/etc/man/cargo-uninstall.1
new file mode 100644
index 0000000..be35a81
--- /dev/null
+++ b/src/etc/man/cargo-uninstall.1
@@ -0,0 +1,160 @@
+'\" t
+.TH "CARGO\-UNINSTALL" "1"
+.nh
+.ad l
+.ss \n[.ss] 0
+.SH "NAME"
+cargo\-uninstall \[em] Remove a Rust binary
+.SH "SYNOPSIS"
+\fBcargo uninstall\fR [\fIoptions\fR] [\fIspec\fR\[u2026]]
+.SH "DESCRIPTION"
+This command removes a package installed with \fBcargo\-install\fR(1). The \fIspec\fR
+argument is a package ID specification of the package to remove (see
+\fBcargo\-pkgid\fR(1)).
+.sp
+By default all binaries are removed for a crate but the \fB\-\-bin\fR and
+\fB\-\-example\fR flags can be used to only remove particular binaries.
+.sp
+The installation root is determined, in order of precedence:
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fB\-\-root\fR option
+.RE
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fBCARGO_INSTALL_ROOT\fR environment variable
+.RE
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fBinstall.root\fR Cargo \fIconfig value\fR <https://doc.rust\-lang.org/cargo/reference/config.html>
+.RE
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fBCARGO_HOME\fR environment variable
+.RE
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fB$HOME/.cargo\fR
+.RE
+.SH "OPTIONS"
+.SS "Install Options"
+.sp
+\fB\-p\fR,
+\fB\-\-package\fR \fIspec\fR\[u2026]
+.RS 4
+Package to uninstall.
+.RE
+.sp
+\fB\-\-bin\fR \fIname\fR\[u2026]
+.RS 4
+Only uninstall the binary \fIname\fR\&.
+.RE
+.sp
+\fB\-\-root\fR \fIdir\fR
+.RS 4
+Directory to uninstall packages from.
+.RE
+.SS "Display Options"
+.sp
+\fB\-v\fR,
+\fB\-\-verbose\fR
+.RS 4
+Use verbose output. May be specified twice for \[lq]very verbose\[rq] output which
+includes extra output such as dependency warnings and build script output.
+May also be specified with the \fBterm.verbose\fR
+\fIconfig value\fR <https://doc.rust\-lang.org/cargo/reference/config.html>\&.
+.RE
+.sp
+\fB\-q\fR,
+\fB\-\-quiet\fR
+.RS 4
+Do not print cargo log messages.
+May also be specified with the \fBterm.quiet\fR
+\fIconfig value\fR <https://doc.rust\-lang.org/cargo/reference/config.html>\&.
+.RE
+.sp
+\fB\-\-color\fR \fIwhen\fR
+.RS 4
+Control when colored output is used. Valid values:
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fBauto\fR (default): Automatically detect if color support is available on the
+terminal.
+.RE
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fBalways\fR: Always display colors.
+.RE
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fBnever\fR: Never display colors.
+.RE
+.sp
+May also be specified with the \fBterm.color\fR
+\fIconfig value\fR <https://doc.rust\-lang.org/cargo/reference/config.html>\&.
+.RE
+.SS "Common Options"
+.sp
+\fB+\fR\fItoolchain\fR
+.RS 4
+If Cargo has been installed with rustup, and the first argument to \fBcargo\fR
+begins with \fB+\fR, it will be interpreted as a rustup toolchain name (such
+as \fB+stable\fR or \fB+nightly\fR).
+See the \fIrustup documentation\fR <https://rust\-lang.github.io/rustup/overrides.html>
+for more information about how toolchain overrides work.
+.RE
+.sp
+\fB\-\-config\fR \fIKEY=VALUE\fR or \fIPATH\fR
+.RS 4
+Overrides a Cargo configuration value. The argument should be in TOML syntax of \fBKEY=VALUE\fR,
+or provided as a path to an extra configuration file. This flag may be specified multiple times.
+See the \fIcommand\-line overrides section\fR <https://doc.rust\-lang.org/cargo/reference/config.html#command\-line\-overrides> for more information.
+.RE
+.sp
+\fB\-C\fR \fIPATH\fR
+.RS 4
+Changes the current working directory before executing any specified operations. This affects
+things like where cargo looks by default for the project manifest (\fBCargo.toml\fR), as well as
+the directories searched for discovering \fB\&.cargo/config.toml\fR, for example.
+.sp
+This option is only available on the \fInightly
+channel\fR <https://doc.rust\-lang.org/book/appendix\-07\-nightly\-rust.html> and
+requires the \fB\-Z unstable\-options\fR flag to enable (see
+\fI#10098\fR <https://github.com/rust\-lang/cargo/issues/10098>).
+.RE
+.sp
+\fB\-h\fR,
+\fB\-\-help\fR
+.RS 4
+Prints help information.
+.RE
+.sp
+\fB\-Z\fR \fIflag\fR
+.RS 4
+Unstable (nightly\-only) flags to Cargo. Run \fBcargo \-Z help\fR for details.
+.RE
+.SH "ENVIRONMENT"
+See \fIthe reference\fR <https://doc.rust\-lang.org/cargo/reference/environment\-variables.html> for
+details on environment variables that Cargo reads.
+.SH "EXIT STATUS"
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fB0\fR: Cargo succeeded.
+.RE
+.sp
+.RS 4
+\h'-04'\(bu\h'+02'\fB101\fR: Cargo failed to complete.
+.RE
+.SH "EXAMPLES"
+.sp
+.RS 4
+\h'-04' 1.\h'+01'Uninstall a previously installed package.
+.sp
+.RS 4
+.nf
+cargo uninstall ripgrep
+.fi
+.RE
+.RE
+.SH "SEE ALSO"
+\fBcargo\fR(1), \fBcargo\-install\fR(1)