summaryrefslogtreecommitdiffstats
path: root/vendor/libz-sys/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/libz-sys/Cargo.toml')
-rw-r--r--vendor/libz-sys/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/vendor/libz-sys/Cargo.toml b/vendor/libz-sys/Cargo.toml
new file mode 100644
index 0000000..ed22f1c
--- /dev/null
+++ b/vendor/libz-sys/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "libz-sys"
+version = "1.1.12"
+authors = [
+ "Alex Crichton <alex@alexcrichton.com>",
+ "Josh Triplett <josh@joshtriplett.org>",
+ "Sebastian Thiel <sebastian.thiel@icloud.com>",
+]
+links = "z"
+exclude = [
+ "/.github",
+ "/.gitmodules",
+ "/Cargo-zng.toml",
+ "/cargo-zng",
+ "/ci",
+ "/systest",
+]
+description = "Low-level bindings to the system libz library (also known as zlib)."
+readme = "README.md"
+keywords = [
+ "zlib",
+ "zlib-ng",
+]
+categories = [
+ "compression",
+ "external-ffi-bindings",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/rust-lang/libz-sys"
+
+[dependencies.libc]
+version = "0.2.43"
+optional = true
+
+[build-dependencies.pkg-config]
+version = "0.3.9"
+
+[build-dependencies.vcpkg]
+version = "0.2"
+
+[features]
+asm = []
+default = [
+ "libc",
+ "stock-zlib",
+]
+stock-zlib = []