summaryrefslogtreecommitdiffstats
path: root/vendor/openssl-sys/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/openssl-sys/debian/patches')
-rw-r--r--vendor/openssl-sys/debian/patches/disable-bssl.patch15
-rw-r--r--vendor/openssl-sys/debian/patches/disable-vendor.patch30
-rw-r--r--vendor/openssl-sys/debian/patches/relax-bindgen.diff36
-rw-r--r--vendor/openssl-sys/debian/patches/series3
4 files changed, 84 insertions, 0 deletions
diff --git a/vendor/openssl-sys/debian/patches/disable-bssl.patch b/vendor/openssl-sys/debian/patches/disable-bssl.patch
new file mode 100644
index 0000000..e624925
--- /dev/null
+++ b/vendor/openssl-sys/debian/patches/disable-bssl.patch
@@ -0,0 +1,15 @@
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -30,10 +30,6 @@
+ [package.metadata.pkg-config]
+ openssl = "1.0.1"
+
+-[dependencies.bssl-sys]
+-version = "0.1.0"
+-optional = true
+-
+ [dependencies.libc]
+ version = "0.2"
+
+@@ -54,1 +51,0 @@
+-unstable_boringssl = ["bssl-sys"]
diff --git a/vendor/openssl-sys/debian/patches/disable-vendor.patch b/vendor/openssl-sys/debian/patches/disable-vendor.patch
new file mode 100644
index 0000000..aa033cb
--- /dev/null
+++ b/vendor/openssl-sys/debian/patches/disable-vendor.patch
@@ -0,0 +1,30 @@
+--- a/Cargo.toml
++++ b/Cargo.toml
+@@ -50,5 +50,0 @@
+-[build-dependencies.openssl-src]
+-version = "300.1.2"
+-features = ["legacy"]
+-optional = true
+-
+@@ -60,1 +60,0 @@
+-vendored = ["openssl-src"]
+--- a/build/main.rs
++++ b/build/main.rs
+@@ -20,2 +20,0 @@
+-#[cfg(feature = "vendored")]
+-mod find_vendored;
+@@ -49,14 +47,6 @@
+ }
+
+ fn find_openssl(target: &str) -> (Vec<PathBuf>, PathBuf) {
+- #[cfg(feature = "vendored")]
+- {
+- // vendor if the feature is present, unless
+- // OPENSSL_NO_VENDOR exists and isn't `0`
+- if env("OPENSSL_NO_VENDOR").map_or(true, |s| s == "0") {
+- return find_vendored::get_openssl(target);
+- }
+- }
+ find_normal::get_openssl(target)
+ }
+
diff --git a/vendor/openssl-sys/debian/patches/relax-bindgen.diff b/vendor/openssl-sys/debian/patches/relax-bindgen.diff
new file mode 100644
index 0000000..f3ac241
--- /dev/null
+++ b/vendor/openssl-sys/debian/patches/relax-bindgen.diff
@@ -0,0 +1,36 @@
+Relax bindgen dependency to allow any 0.x version greater than 0.60. Tested
+with versions 0.60 and 0.66.
+
+Some options to bindgen that are not available in 0.60 are disabled, this
+is likely to break builds against boringssl (which we don't have in Debian
+anyway).
+
+Index: openssl-sys/Cargo.toml
+===================================================================
+--- openssl-sys.orig/Cargo.toml
++++ openssl-sys/Cargo.toml
+@@ -35,8 +35,7 @@ openssl = "1.0.1"
+ version = "0.2"
+
+ [build-dependencies.bindgen]
+-version = "0.64.0"
+-features = ["experimental"]
++version = ">= 0.60, < 1.0"
+ optional = true
+
+ [build-dependencies.cc]
+Index: openssl-sys/build/run_bindgen.rs
+===================================================================
+--- openssl-sys.orig/build/run_bindgen.rs
++++ openssl-sys/build/run_bindgen.rs
+@@ -123,8 +123,8 @@ pub fn run_boringssl(include_dirs: &[Pat
+ .allowlist_recursively(false)
+ .blocklist_function("BIO_vsnprintf")
+ .blocklist_function("OPENSSL_vasprintf")
+- .wrap_static_fns(true)
+- .wrap_static_fns_path(out_dir.join("boring_static_wrapper").display().to_string())
++ //.wrap_static_fns(true)
++ //.wrap_static_fns_path(out_dir.join("boring_static_wrapper").display().to_string())
+ .layout_tests(false)
+ .header_contents("includes.h", INCLUDES);
+
diff --git a/vendor/openssl-sys/debian/patches/series b/vendor/openssl-sys/debian/patches/series
new file mode 100644
index 0000000..70b4508
--- /dev/null
+++ b/vendor/openssl-sys/debian/patches/series
@@ -0,0 +1,3 @@
+disable-vendor.patch
+disable-bssl.patch
+relax-bindgen.diff