summaryrefslogtreecommitdiffstats
path: root/vendor/pkcs8/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/pkcs8/Cargo.toml')
-rw-r--r--vendor/pkcs8/Cargo.toml108
1 files changed, 108 insertions, 0 deletions
diff --git a/vendor/pkcs8/Cargo.toml b/vendor/pkcs8/Cargo.toml
new file mode 100644
index 0000000..d836551
--- /dev/null
+++ b/vendor/pkcs8/Cargo.toml
@@ -0,0 +1,108 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.65"
+name = "pkcs8"
+version = "0.10.2"
+authors = ["RustCrypto Developers"]
+description = """
+Pure Rust implementation of Public-Key Cryptography Standards (PKCS) #8:
+Private-Key Information Syntax Specification (RFC 5208), with additional
+support for PKCS#8v2 asymmetric key packages (RFC 5958)
+"""
+readme = "README.md"
+keywords = [
+ "crypto",
+ "key",
+ "pkcs",
+ "private",
+]
+categories = [
+ "cryptography",
+ "data-structures",
+ "encoding",
+ "no-std",
+ "parser-implementations",
+]
+license = "Apache-2.0 OR MIT"
+repository = "https://github.com/RustCrypto/formats/tree/master/pkcs8"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.der]
+version = "0.7"
+features = ["oid"]
+
+[dependencies.pkcs5]
+version = "0.7"
+optional = true
+
+[dependencies.rand_core]
+version = "0.6"
+optional = true
+default-features = false
+
+[dependencies.spki]
+version = "0.7.1"
+
+[dependencies.subtle]
+version = "2"
+optional = true
+default-features = false
+
+[dev-dependencies.hex-literal]
+version = "0.3"
+
+[dev-dependencies.tempfile]
+version = "3"
+
+[features]
+3des = [
+ "encryption",
+ "pkcs5/3des",
+]
+alloc = [
+ "der/alloc",
+ "der/zeroize",
+ "spki/alloc",
+]
+des-insecure = [
+ "encryption",
+ "pkcs5/des-insecure",
+]
+encryption = [
+ "alloc",
+ "pkcs5/alloc",
+ "pkcs5/pbes2",
+ "rand_core",
+]
+getrandom = ["rand_core/getrandom"]
+pem = [
+ "alloc",
+ "der/pem",
+ "spki/pem",
+]
+sha1-insecure = [
+ "encryption",
+ "pkcs5/sha1-insecure",
+]
+std = [
+ "alloc",
+ "der/std",
+ "spki/std",
+]