summaryrefslogtreecommitdiffstats
path: root/vendor/powerfmt/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/powerfmt/Cargo.toml')
-rw-r--r--vendor/powerfmt/Cargo.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/vendor/powerfmt/Cargo.toml b/vendor/powerfmt/Cargo.toml
new file mode 100644
index 0000000..f7acec3
--- /dev/null
+++ b/vendor/powerfmt/Cargo.toml
@@ -0,0 +1,59 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.67.0"
+name = "powerfmt"
+version = "0.2.0"
+authors = ["Jacob Pratt <jacob@jhpratt.dev>"]
+description = """
+ `powerfmt` is a library that provides utilities for formatting values. This crate makes it
+ significantly easier to support filling to a minimum width with alignment, avoid heap
+ allocation, and avoid repetitive calculations.
+"""
+readme = "README.md"
+keywords = [
+ "display",
+ "format",
+ "fmt",
+ "formatter",
+ "extension",
+]
+categories = [
+ "no-std",
+ "no-std::no-alloc",
+ "rust-patterns",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/jhpratt/powerfmt"
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "__powerfmt_docs",
+ "--generate-link-to-definition",
+]
+targets = ["x86_64-unknown-linux-gnu"]
+
+[dependencies.powerfmt-macros]
+version = "=0.1.0"
+optional = true
+
+[features]
+alloc = []
+default = [
+ "std",
+ "macros",
+]
+macros = ["dep:powerfmt-macros"]
+std = ["alloc"]