summaryrefslogtreecommitdiffstats
path: root/vendor/rustc-workspace-hack
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/rustc-workspace-hack')
-rw-r--r--vendor/rustc-workspace-hack/.cargo-checksum.json1
-rw-r--r--vendor/rustc-workspace-hack/Cargo.toml20
-rw-r--r--vendor/rustc-workspace-hack/src/lib.rs7
3 files changed, 28 insertions, 0 deletions
diff --git a/vendor/rustc-workspace-hack/.cargo-checksum.json b/vendor/rustc-workspace-hack/.cargo-checksum.json
new file mode 100644
index 0000000..f24f636
--- /dev/null
+++ b/vendor/rustc-workspace-hack/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{},"package":"fc71d2faa173b74b232dedc235e3ee1696581bb132fc116fa3626d6151a1a8fb"} \ No newline at end of file
diff --git a/vendor/rustc-workspace-hack/Cargo.toml b/vendor/rustc-workspace-hack/Cargo.toml
new file mode 100644
index 0000000..e965c6a
--- /dev/null
+++ b/vendor/rustc-workspace-hack/Cargo.toml
@@ -0,0 +1,20 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g. crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "rustc-workspace-hack"
+version = "1.0.0"
+authors = ["Alex Crichton <alex@alexcrichton.com>"]
+description = "Hack for the compiler's own build system\n"
+license = "MIT/Apache-2.0"
+
+[dependencies]
diff --git a/vendor/rustc-workspace-hack/src/lib.rs b/vendor/rustc-workspace-hack/src/lib.rs
new file mode 100644
index 0000000..31e1bb2
--- /dev/null
+++ b/vendor/rustc-workspace-hack/src/lib.rs
@@ -0,0 +1,7 @@
+#[cfg(test)]
+mod tests {
+ #[test]
+ fn it_works() {
+ assert_eq!(2 + 2, 4);
+ }
+}