summaryrefslogtreecommitdiffstats
path: root/vendor/snapbox-macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'vendor/snapbox-macros/Cargo.toml')
-rw-r--r--vendor/snapbox-macros/Cargo.toml50
1 files changed, 50 insertions, 0 deletions
diff --git a/vendor/snapbox-macros/Cargo.toml b/vendor/snapbox-macros/Cargo.toml
new file mode 100644
index 0000000..398ecfd
--- /dev/null
+++ b/vendor/snapbox-macros/Cargo.toml
@@ -0,0 +1,50 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.70.0"
+name = "snapbox-macros"
+version = "0.3.6"
+include = [
+ "build.rs",
+ "src/**/*",
+ "Cargo.toml",
+ "LICENSE*",
+ "README.md",
+ "benches/**/*",
+ "examples/**/*",
+]
+description = "Snapshot testing toolbox"
+homepage = "https://github.com/assert-rs/trycmd/tree/main/crates/snapbox"
+documentation = "http://docs.rs/snapbox/"
+readme = "README.md"
+keywords = [
+ "cli",
+ "test",
+ "assert",
+ "command",
+]
+categories = ["development-tools::testing"]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/assert-rs/trycmd/"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[dependencies.anstream]
+version = "0.6.0"
+optional = true
+
+[features]
+color = ["dep:anstream"]
+debug = []
+default = []