summaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:40:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:40:13 +0000
commite9be59e1502a41bab9891d96d753102a7dafef0b (patch)
treec3b2da87c414881f4b53d0964f407c83492d813e /config
parentInitial commit. (diff)
downloadcluster-glue-e9be59e1502a41bab9891d96d753102a7dafef0b.tar.xz
cluster-glue-e9be59e1502a41bab9891d96d753102a7dafef0b.zip
Adding upstream version 1.0.12.upstream/1.0.12upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'config')
-rw-r--r--config/Makefile.am19
-rw-r--r--config/byteorder_test.c15
2 files changed, 34 insertions, 0 deletions
diff --git a/config/Makefile.am b/config/Makefile.am
new file mode 100644
index 0000000..fa41516
--- /dev/null
+++ b/config/Makefile.am
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2005 Guochun Shi (gshi@ncsa.uiuc.edu)
+#
+# This program is free software; you can redistribute it and/or
+# modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation; either version 2
+# of the License, or (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+
+MAINTAINERCLEANFILES = Makefile.in
+EXTRA_DIST = byteorder_test.c
diff --git a/config/byteorder_test.c b/config/byteorder_test.c
new file mode 100644
index 0000000..0583803
--- /dev/null
+++ b/config/byteorder_test.c
@@ -0,0 +1,15 @@
+#include <stdio.h>
+
+int
+main ()
+{
+ unsigned int a = 0x1234;
+
+ if ( (unsigned int) ( ((unsigned char *)&a)[0]) == 0x34 ) {
+ printf("little-endian\n");
+ return 0;
+ } else {
+ printf("big-endian\n");
+ return 1;
+ }
+}