summaryrefslogtreecommitdiffstats
path: root/lib/plugins/lrm/dbus/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/plugins/lrm/dbus/Makefile.am')
-rw-r--r--lib/plugins/lrm/dbus/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/lib/plugins/lrm/dbus/Makefile.am b/lib/plugins/lrm/dbus/Makefile.am
new file mode 100644
index 0000000..ec93436
--- /dev/null
+++ b/lib/plugins/lrm/dbus/Makefile.am
@@ -0,0 +1,16 @@
+if UPSTART
+BINDINGS=Upstart_Instance.h \
+ Upstart_Job.h \
+ Upstart.h
+
+all-local:
+ for header in $(BINDINGS); do \
+ input=com.ubuntu.`echo $$header | sed 's/\.h//' | tr _ .`.xml; \
+ $(DBUS_BINDING_TOOL) --mode=glib-client $$input > $$header; \
+ done
+
+clean-local:
+ rm -f $(BINDINGS)
+
+EXTRA_DIST = *.xml
+endif