summaryrefslogtreecommitdiffstats
path: root/bindings/rust/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 17:01:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 17:01:24 +0000
commit6dd3dfb79125cd02d02efbce435a6c82e5af92ef (patch)
tree45084fc83278586f6bbafcb935f92d53f71a6b03 /bindings/rust/Makefile.am
parentInitial commit. (diff)
downloadcorosync-6dd3dfb79125cd02d02efbce435a6c82e5af92ef.tar.xz
corosync-6dd3dfb79125cd02d02efbce435a6c82e5af92ef.zip
Adding upstream version 3.1.8.upstream/3.1.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bindings/rust/Makefile.am')
-rw-r--r--bindings/rust/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/bindings/rust/Makefile.am b/bindings/rust/Makefile.am
new file mode 100644
index 0000000..c22b84b
--- /dev/null
+++ b/bindings/rust/Makefile.am
@@ -0,0 +1,60 @@
+#
+# Copyright (C) 2022-2023 Red Hat, Inc. All rights reserved.
+#
+# Author: Christine Caulfield <ccaulfie@redhat.com>
+#
+# This software licensed under GPL-2.0+
+#
+
+MAINTAINERCLEANFILES = Makefile.in
+
+include $(top_srcdir)/build-aux/rust.mk
+
+# required for make check
+localver = $(corosyncrustver)
+
+SUBDIRS = . tests
+
+EXTRA_DIST = \
+ $(RUST_COMMON) \
+ $(RUST_SHIP_SRCS) \
+ README.md
+
+RUST_SHIP_SRCS = \
+ src/cpg.rs \
+ src/cfg.rs \
+ src/quorum.rs \
+ src/votequorum.rs \
+ src/cmap.rs \
+ src/lib.rs \
+ src/sys/mod.rs
+
+RUST_BUILT_SRCS = \
+ src/sys/cpg.rs \
+ src/sys/cfg.rs \
+ src/sys/quorum.rs \
+ src/sys/votequorum.rs \
+ src/sys/cmap.rs
+
+src/sys/cpg.rs: cargo-tree-prep ../../include/corosync/cpg.h
+ $(top_srcdir)/build-aux/rust-regen.sh $(top_srcdir)/include/corosync/cpg.h $@ CPG --blocklist-function=inet6.* --blocklist-function==.*etsourcefilter -- -I$(top_srcdir)/include
+
+src/sys/cfg.rs: cargo-tree-prep ../../include/corosync/cfg.h
+ $(top_srcdir)/build-aux/rust-regen.sh $(top_srcdir)/include/corosync/cfg.h $@ CFG --blocklist-function=inet6.* --blocklist-function=.*etsourcefilter -- -I$(top_srcdir)/include
+
+src/sys/quorum.rs: cargo-tree-prep ../../include/corosync/quorum.h
+ $(top_srcdir)/build-aux/rust-regen.sh $(top_srcdir)/include/corosync/quorum.h $@ QUORUM -- -I$(top_srcdir)/include
+
+src/sys/votequorum.rs: cargo-tree-prep ../../include/corosync/votequorum.h
+ $(top_srcdir)/build-aux/rust-regen.sh $(top_srcdir)/include/corosync/votequorum.h $@ VOTEQUORUM -- -I$(top_srcdir)/include
+
+src/sys/cmap.rs: cargo-tree-prep ../../include/corosync/cmap.h
+ $(top_srcdir)/build-aux/rust-regen.sh $(top_srcdir)/include/corosync/cmap.h $@ CMAP -- -I$(top_srcdir)/include $(LIBQB_CFLAGS)
+
+all-local: target/$(RUST_TARGET_DIR)/cpg.rlib \
+ target/$(RUST_TARGET_DIR)/cfg.rlib \
+ target/$(RUST_TARGET_DIR)/quorum.rlib \
+ target/$(RUST_TARGET_DIR)/votequorum.rlib \
+ target/$(RUST_TARGET_DIR)/cmap.rlib
+
+clean-local: cargo-clean