summaryrefslogtreecommitdiffstats
path: root/bindings/rust/tests/Cargo.toml.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 17:01:24 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-06-03 17:01:24 +0000
commit6dd3dfb79125cd02d02efbce435a6c82e5af92ef (patch)
tree45084fc83278586f6bbafcb935f92d53f71a6b03 /bindings/rust/tests/Cargo.toml.in
parentInitial commit. (diff)
downloadcorosync-6dd3dfb79125cd02d02efbce435a6c82e5af92ef.tar.xz
corosync-6dd3dfb79125cd02d02efbce435a6c82e5af92ef.zip
Adding upstream version 3.1.8.upstream/3.1.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bindings/rust/tests/Cargo.toml.in')
-rw-r--r--bindings/rust/tests/Cargo.toml.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/bindings/rust/tests/Cargo.toml.in b/bindings/rust/tests/Cargo.toml.in
new file mode 100644
index 0000000..1d8fabf
--- /dev/null
+++ b/bindings/rust/tests/Cargo.toml.in
@@ -0,0 +1,36 @@
+[package]
+name = "rust-corosync-tests"
+version = "@corosyncrustver@"
+authors = ["Christine Caulfield <ccaulfie@redhat.com>"]
+edition = "2021"
+
+[dependencies]
+rust-corosync = { path = ".." }
+
+[build-dependencies]
+pkg-config = "0.3"
+
+[[bin]]
+name = "cpg-test"
+test = false
+bench = false
+
+[[bin]]
+name = "quorum-test"
+test = false
+bench = false
+
+[[bin]]
+name = "votequorum-test"
+test = false
+bench = false
+
+[[bin]]
+name = "cfg-test"
+test = false
+bench = false
+
+[[bin]]
+name = "cmap-test"
+test = false
+bench = false