summaryrefslogtreecommitdiffstats
path: root/bindings/rust/tests/Cargo.toml.in
diff options
context:
space:
mode:
Diffstat (limited to 'bindings/rust/tests/Cargo.toml.in')
-rw-r--r--bindings/rust/tests/Cargo.toml.in36
1 files changed, 36 insertions, 0 deletions
diff --git a/bindings/rust/tests/Cargo.toml.in b/bindings/rust/tests/Cargo.toml.in
new file mode 100644
index 0000000..1d8fabf
--- /dev/null
+++ b/bindings/rust/tests/Cargo.toml.in
@@ -0,0 +1,36 @@
+[package]
+name = "rust-corosync-tests"
+version = "@corosyncrustver@"
+authors = ["Christine Caulfield <ccaulfie@redhat.com>"]
+edition = "2021"
+
+[dependencies]
+rust-corosync = { path = ".." }
+
+[build-dependencies]
+pkg-config = "0.3"
+
+[[bin]]
+name = "cpg-test"
+test = false
+bench = false
+
+[[bin]]
+name = "quorum-test"
+test = false
+bench = false
+
+[[bin]]
+name = "votequorum-test"
+test = false
+bench = false
+
+[[bin]]
+name = "cfg-test"
+test = false
+bench = false
+
+[[bin]]
+name = "cmap-test"
+test = false
+bench = false