summaryrefslogtreecommitdiffstats
path: root/vqsim/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'vqsim/Makefile.am')
-rw-r--r--vqsim/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/vqsim/Makefile.am b/vqsim/Makefile.am
new file mode 100644
index 0000000..7639fcf
--- /dev/null
+++ b/vqsim/Makefile.am
@@ -0,0 +1,57 @@
+#
+# Copyright (c) 2009 Red Hat, Inc.
+#
+# Authors: Andrew Beekhof
+# Steven Dake (sdake@redhat.com)
+#
+# This software licensed under BSD license, the text of which follows:
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# - Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# - Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+# - Neither the name of the MontaVista Software, Inc. nor the names of its
+# contributors may be used to endorse or promote products derived from this
+# software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
+# AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+# ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE
+# LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+# CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+# SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+# CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+# ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
+# THE POSSIBILITY OF SUCH DAMAGE.
+
+MAINTAINERCLEANFILES = Makefile.in
+
+if BUILD_VQSIM
+
+noinst_HEADERS = vqsim.h
+
+bin_PROGRAMS = corosync-vqsim
+
+corosync_vqsim_CFLAGS = $(knet_CFLAGS)
+
+corosync_vqsim_LDADD = $(top_builddir)/common_lib/libcorosync_common.la \
+ ../exec/corosync-votequorum.o ../exec/corosync-icmap.o \
+ ../exec/corosync-coroparse.o ../exec/corosync-logconfig.o \
+ ../exec/corosync-util.o ../exec/corosync-logsys.o \
+ $(LIBQB_LIBS) $(knet_LIBS)
+
+if VQSIM_READLINE
+corosync_vqsim_LDADD += -lreadline
+endif
+
+corosync_vqsim_DEPENDENCIES = $(top_builddir)/common_lib/libcorosync_common.la
+
+corosync_vqsim_SOURCES = vqmain.c parser.c vq_object.c vqsim_vq_engine.c
+
+endif