summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:48:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 06:48:59 +0000
commitd835b2cae8abc71958b69362162e6a70c3d7ef63 (patch)
tree81052e3d2ce3e1bcda085f73d925e9d6257dec15 /setup.py
parentInitial commit. (diff)
downloadcrmsh-d835b2cae8abc71958b69362162e6a70c3d7ef63.tar.xz
crmsh-d835b2cae8abc71958b69362162e6a70c3d7ef63.zip
Adding upstream version 4.6.0.upstream/4.6.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..d13d998
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/env python3
+# Note that this script only installs the python modules,
+# the other parts of crmsh are installed by autotools
+from setuptools import setup
+import contextlib
+import re
+
+VERSION = '0.0.1'
+
+with contextlib.suppress(Exception):
+ with open('version', 'r', encoding='ascii') as f:
+ match = re.match('^\\d+\\.\\d+\\.\\d+', f.read().strip())
+ if match:
+ VERSION = match.group(0)
+
+setup(name='crmsh',
+ version=VERSION,
+ description='Command-line interface for High-Availability cluster management',
+ author='Kristoffer Gronlund, Xin Liang',
+ author_email='XLiang@suse.com',
+ url='http://crmsh.github.io/',
+ packages=['crmsh', 'crmsh.crash_test', 'crmsh.report', 'crmsh.prun'],
+ install_requires=['lxml', 'PyYAML', 'python-dateutil'],
+ scripts=['bin/crm'],
+ data_files=[('/usr/share/crmsh', ['doc/crm.8.adoc'])],
+ include_package_data=True)