summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..e1d8c0d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,25 @@
+CFLAGS += -Wall -O2
+LDLIBS += -lcrypt
+
+EXECUTABLES = crypt
+
+all: $(EXECUTABLES)
+
+check:
+ ./check
+
+clean:
+ rm -f *.o
+ rm -f $(EXECUTABLES)
+
+install: $(EXECUTABLES)
+ mkdir -p $(DESTDIR)/lib/cryptsetup
+ cp askpass $(DESTDIR)/lib/cryptsetup/
+
+ mkdir -p $(DESTDIR)/usr/share/initramfs-tools/hooks/
+ cp hooks/* $(DESTDIR)/usr/share/initramfs-tools/hooks/
+
+ mkdir -p $(DESTDIR)/usr/lib/cryptsetup-nuke-password
+ cp crypt $(DESTDIR)/usr/lib/cryptsetup-nuke-password/
+
+.PHONY: check clean install