summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:29:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:33:52 +0000
commit9d65932065ea7d24a6e3d2f209e02527ab0e50ad (patch)
treeb5f5caf4cddde528fbf94c848696f26152ec3fec
parentUpdating vcs fields. (diff)
downloadcryptsetup-9d65932065ea7d24a6e3d2f209e02527ab0e50ad.tar.xz
cryptsetup-9d65932065ea7d24a6e3d2f209e02527ab0e50ad.zip
Using decrypt_keyctl by default if no keyscript in /etc/crypttab to cache passphrase for multiple filesystems.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/control3
-rw-r--r--debian/functions5
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index cfd41f8..a885251 100644
--- a/debian/control
+++ b/debian/control
@@ -46,9 +46,10 @@ Architecture: linux-any
Multi-Arch: foreign
Depends: cryptsetup-bin (>= 2:1.6.0),
dmsetup,
+ keyutils,
${misc:Depends},
${shlibs:Depends}
-Suggests: cryptsetup-initramfs, dosfstools, keyutils, liblocale-gettext-perl
+Suggests: cryptsetup-initramfs, dosfstools, liblocale-gettext-perl
Description: disk encryption support - startup scripts
Cryptsetup provides an interface for configuring encryption on block
devices (such as /home or swap partitions), using the Linux kernel
diff --git a/debian/functions b/debian/functions
index 917abad..3409787 100644
--- a/debian/functions
+++ b/debian/functions
@@ -113,6 +113,11 @@ crypttab_parse_options() {
done
IFS=" "
+ # use decrypt_keyctl by default if no keyscript in /etc/crypttab
+ if [ -z "$CRYPTTAB_OPTION_keyscript" ]; then
+ CRYPTTAB_OPTION_keyscript="/lib/cryptsetup/scripts/decrypt_keyctl"
+ fi
+
if ! _get_crypt_type; then # set CRYPTTAB_TYPE to the type of crypt device
CRYPTTAB_TYPE="plain"
if [ "$quiet" = "n" ]; then