summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:37:18 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:37:18 +0000
commit82adb3ced76821078f4cd08f73fa8271d225a9a5 (patch)
treea70950ee1ddd4c9623896b14e4e44f61cfec7d3a /meson.build
parentReleasing progress-linux version 2:2.7.0-1~progress7.99u1. (diff)
downloadcryptsetup-82adb3ced76821078f4cd08f73fa8271d225a9a5.tar.xz
cryptsetup-82adb3ced76821078f4cd08f73fa8271d225a9a5.zip
Merging upstream version 2:2.7.1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 5 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index b26c71c..1b8d504 100644
--- a/meson.build
+++ b/meson.build
@@ -2,7 +2,7 @@ project('cryptsetup',
'c',
default_options: [ 'prefix=/usr' ],
meson_version: '>=0.64',
- version: '2.7.0')
+ version: '2.7.1')
libcryptsetup_version = '12.10.0'
@@ -512,6 +512,9 @@ elif get_option('crypto-backend') == 'openssl'
conf.set10('HAVE_DECL_OSSL_KDF_PARAM_ARGON2_VERSION',
cc.has_header_symbol('openssl/core_names.h', 'OSSL_KDF_PARAM_ARGON2_VERSION',
dependencies: crypto_backend_library))
+ if conf.get('HAVE_DECL_OSSL_KDF_PARAM_ARGON2_VERSION') == 1
+ use_internal_argon2 = false
+ endif
elif get_option('crypto-backend') == 'nss'
if get_option('fips')
error('nss crypto backend is not supported with FIPS enabled')
@@ -560,7 +563,7 @@ threads = []
use_internal_sse_argon2 = false
if not use_internal_argon2 or get_option('argon-implementation') == 'none'
if get_option('argon-implementation') == 'internal' or get_option('argon-implementation') == 'libargon2'
- warning('Argon2 in crypto library is used; internal Argon2 options are ignored.')
+ message('Argon2 in crypto library is used; internal Argon2 options are ignored.')
endif
conf.set10('USE_INTERNAL_ARGON2', false,
description: 'Use internal Argon2.')