summaryrefslogtreecommitdiffstats
path: root/tests/fuzz/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:35:42 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-17 08:35:42 +0000
commit8909d83a3ed226e4a7c962261217cb2c14ff2ec9 (patch)
tree6244f99976b171d94833db21dc498c3a89d04fe4 /tests/fuzz/meson.build
parentReleasing progress-linux version 2:2.6.1-6~progress7.99u1. (diff)
downloadcryptsetup-8909d83a3ed226e4a7c962261217cb2c14ff2ec9.tar.xz
cryptsetup-8909d83a3ed226e4a7c962261217cb2c14ff2ec9.zip
Merging upstream version 2:2.7.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/fuzz/meson.build')
-rw-r--r--tests/fuzz/meson.build127
1 files changed, 127 insertions, 0 deletions
diff --git a/tests/fuzz/meson.build b/tests/fuzz/meson.build
new file mode 100644
index 0000000..95ea382
--- /dev/null
+++ b/tests/fuzz/meson.build
@@ -0,0 +1,127 @@
+if get_option('fuzz-targets')
+ crypt2_load_fuzz = executable('crypt2_load_fuzz',
+ [
+ 'crypt2_load_fuzz.cc',
+ ],
+ dependencies: [
+ devmapper,
+ fuzzing_engine,
+ ],
+ link_with: [
+ libcryptsetup,
+ libcrypto_backend,
+ libutils_io,
+ ],
+ link_args: [
+ link_args,
+ ],
+ include_directories: includes_tools)
+
+ crypt2_load_ondisk_fuzz = executable('crypt2_load_ondisk_fuzz',
+ [
+ 'crypt2_load_ondisk_fuzz.cc',
+ ],
+ dependencies: [
+ devmapper,
+ fuzzing_engine,
+ ],
+ link_with: [
+ libcryptsetup,
+ libcrypto_backend,
+ libutils_io,
+ ],
+ link_args: [
+ link_args,
+ ],
+ include_directories: includes_tools)
+
+ luks2_generated = protoc_generator.process('LUKS2.proto')
+ crypt2_load_proto_fuzz = executable('crypt2_load_proto_fuzz',
+ [
+ 'crypt2_load_proto_fuzz.cc',
+ 'proto_to_luks2_converter.cc',
+ luks2_generated,
+ ],
+ dependencies: [
+ devmapper,
+ protobuf,
+ libprotobuf_mutator,
+ fuzzing_engine,
+ ],
+ link_with: [
+ libcryptsetup,
+ libcrypto_backend,
+ libutils_io,
+ ],
+ link_args: [
+ link_args,
+ ],
+ include_directories: includes_tools)
+
+ luks2_plain_json_generated = protoc_generator.process('LUKS2_plain_JSON.proto')
+ crypt2_load_proto_plain_fuzz = executable('crypt2_load_proto_plain_fuzz',
+ [
+ 'crypt2_load_proto_plain_json_fuzz.cc',
+ 'json_proto_converter.cc',
+ 'plain_json_proto_to_luks2_converter.cc',
+ luks2_plain_json_generated,
+ ],
+ dependencies: [
+ devmapper,
+ protobuf,
+ libprotobuf_mutator,
+ fuzzing_engine,
+ ],
+ link_with: [
+ libcryptsetup,
+ libcrypto_backend,
+ libutils_io,
+ ],
+ link_args: [
+ link_args,
+ ],
+ include_directories: includes_tools)
+
+ proto_to_luks2 = executable('proto_to_luks2',
+ [
+ 'proto_to_luks2.cc',
+ 'proto_to_luks2_converter.cc',
+ luks2_generated,
+ ],
+ dependencies: [
+ devmapper,
+ protobuf,
+ libprotobuf_mutator,
+ ],
+ link_with: [
+ libcryptsetup,
+ libcrypto_backend,
+ libutils_io,
+ ],
+ link_args: [
+ link_args,
+ ],
+ include_directories: includes_tools)
+
+ plain_json_proto_to_luks2 = executable('plain_json_proto_to_luks2',
+ [
+ 'plain_json_proto_to_luks2.cc',
+ 'plain_json_proto_to_luks2_converter.cc',
+ 'json_proto_converter.cc',
+ luks2_plain_json_generated,
+ ],
+ dependencies: [
+ devmapper,
+ protobuf,
+ libprotobuf_mutator,
+ ],
+ link_with: [
+ libcryptsetup,
+ libcrypto_backend,
+ libutils_io,
+ ],
+ link_args: [
+ link_args,
+ ],
+ include_directories: includes_tools)
+endif