summaryrefslogtreecommitdiffstats
path: root/tokens/ssh/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tokens/ssh/meson.build')
-rw-r--r--tokens/ssh/meson.build39
1 files changed, 39 insertions, 0 deletions
diff --git a/tokens/ssh/meson.build b/tokens/ssh/meson.build
new file mode 100644
index 0000000..dba1d76
--- /dev/null
+++ b/tokens/ssh/meson.build
@@ -0,0 +1,39 @@
+tokens_ssh_build_dir = meson.current_build_dir()
+
+if get_option('ssh-token')
+ if not enable_static
+ libcryptsetup_token_ssh = shared_library(
+ 'cryptsetup-token-ssh',
+ [
+ 'libcryptsetup-token-ssh.c',
+ 'ssh-utils.c',
+ ],
+ dependencies: [
+ jsonc,
+ libssh,
+ ],
+ link_with: libcryptsetup,
+ link_args: token_link_args,
+ include_directories: includes_tools + ['..'])
+ endif
+
+ cryptsetup_ssh_files = files(
+ 'cryptsetup-ssh.c',
+ 'ssh-utils.c',
+ )
+ cryptsetup_ssh_files += lib_ssh_token_files
+ cryptsetup_ssh_files += src_ssh_token_files
+
+ cryptsetup_ssh = executable('cryptsetup-ssh',
+ cryptsetup_ssh_files,
+ dependencies: [
+ argp,
+ jsonc,
+ libssh,
+ passwdqc,
+ popt,
+ pwquality,
+ ],
+ link_with: libcryptsetup,
+ include_directories: includes_tools + ['..'])
+endif