summaryrefslogtreecommitdiffstats
path: root/dh_listpackages
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 12:53:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-09 12:53:53 +0000
commit90169463f86997737ed5b9c0ea2b311cd3b056b7 (patch)
tree281a0f8d9850ea58cf2a3ddb8bf087fb52520925 /dh_listpackages
parentInitial commit. (diff)
downloaddebhelper-90169463f86997737ed5b9c0ea2b311cd3b056b7.tar.xz
debhelper-90169463f86997737ed5b9c0ea2b311cd3b056b7.zip
Adding upstream version 13.15.3.upstream/13.15.3upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'dh_listpackages')
-rwxr-xr-xdh_listpackages44
1 files changed, 44 insertions, 0 deletions
diff --git a/dh_listpackages b/dh_listpackages
new file mode 100755
index 0000000..e43e2cd
--- /dev/null
+++ b/dh_listpackages
@@ -0,0 +1,44 @@
+#!/usr/bin/perl
+
+=head1 NAME
+
+dh_listpackages - list binary packages debhelper will act on
+
+=cut
+
+use strict;
+use warnings;
+use Debian::Debhelper::Dh_Lib;
+
+our $VERSION = DH_BUILTIN_VERSION;
+
+=head1 SYNOPSIS
+
+B<dh_listpackages> [S<I<debhelper options>>]
+
+=head1 DESCRIPTION
+
+B<dh_listpackages> is a debhelper program that outputs a list of all binary
+packages debhelper commands will act on. If you pass it some options, it
+will change the list to match the packages other debhelper commands would
+act on if passed the same options.
+
+Packages are listed in the order they appear in F<debian/control>.
+
+=cut
+
+$dh{BLOCK_NOOP_WARNINGS}=1;
+init(inhibit_log => 1);
+print join("\n",@{$dh{DOPACKAGES}})."\n";
+
+=head1 SEE ALSO
+
+L<debhelper(7)>
+
+This program is a part of debhelper.
+
+=head1 AUTHOR
+
+Joey Hess <joeyh@debian.org>
+
+=cut