summaryrefslogtreecommitdiffstats
path: root/src/debputy/commands/debputy_cmd/lint_and_lsp_cmds.py
diff options
context:
space:
mode:
Diffstat (limited to 'src/debputy/commands/debputy_cmd/lint_and_lsp_cmds.py')
-rw-r--r--src/debputy/commands/debputy_cmd/lint_and_lsp_cmds.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/debputy/commands/debputy_cmd/lint_and_lsp_cmds.py b/src/debputy/commands/debputy_cmd/lint_and_lsp_cmds.py
index dcb5063..35b5f6a 100644
--- a/src/debputy/commands/debputy_cmd/lint_and_lsp_cmds.py
+++ b/src/debputy/commands/debputy_cmd/lint_and_lsp_cmds.py
@@ -26,6 +26,9 @@ _EDITOR_SNIPPETS = {
'(debian-changelog-mode . ("debputy" "lsp" "server")))
(add-to-list 'eglot-server-programs
'(debian-copyright-mode . ("debputy" "lsp" "server")))
+ ;; Requires elpa-dpkg-dev-el (>> 37.11)
+ ;; (add-to-list 'eglot-server-programs
+ ;; '(debian-autopkgtest-control-mode . ("debputy" "lsp" "server")))
;; The debian/rules file uses the qmake mode.
(add-to-list 'eglot-server-programs
'(makefile-gmake-mode . ("debputy" "lsp" "server")))
@@ -40,6 +43,8 @@ _EDITOR_SNIPPETS = {
;; opening the first changelog. It seems to be related to imenu.
;; (add-hook 'debian-changelog-mode-hook 'eglot-ensure)
(add-hook 'debian-copyright-mode-hook 'eglot-ensure)
+ ;; Requires elpa-dpkg-dev-el (>> 37.11)
+ ;; (add-hook 'debian-autopkgtest-control-mode-hook 'eglot-ensure)
(add-hook 'makefile-gmake-mode-hook 'eglot-ensure)
(add-hook 'yaml-mode-hook 'eglot-ensure)
"""
@@ -54,6 +59,8 @@ _EDITOR_SNIPPETS = {
# Make vim recognize debputy.manifest as YAML file
au BufNewFile,BufRead debputy.manifest setf yaml
# Inform vim/ycm about the debputy LSP
+ # - NB: No known support for debian/tests/control that we can hook into.
+ # Feel free to provide one :)
let g:ycm_language_server = [
\\ { 'name': 'debputy',
\\ 'filetypes': [ 'debcontrol', 'debcopyright', 'debchangelog', 'make', 'yaml'],