summaryrefslogtreecommitdiffstats
path: root/tests/test_migrations.py
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test_migrations.py')
-rw-r--r--tests/test_migrations.py13
1 files changed, 8 insertions, 5 deletions
diff --git a/tests/test_migrations.py b/tests/test_migrations.py
index 9d43549..f53c716 100644
--- a/tests/test_migrations.py
+++ b/tests/test_migrations.py
@@ -1,6 +1,6 @@
import io
import textwrap
-from typing import Iterable, Callable, Optional, List, Tuple, Sequence
+from typing import Callable, Optional, List, Tuple, Sequence
import pytest
@@ -22,8 +22,6 @@ from debputy.dh_migration.migrators_impl import (
migrate_installinfo_file,
migrate_dh_installsystemd_files,
detect_obsolete_substvars,
- MIGRATION_TARGET_DH_DEBPUTY,
- MIGRATION_TARGET_DH_DEBPUTY_RRR,
detect_dh_addons_zz_debputy_rrr,
)
from debputy.dh_migration.models import (
@@ -34,6 +32,10 @@ from debputy.dh_migration.models import (
from debputy.highlevel_manifest import HighLevelManifest
from debputy.highlevel_manifest_parser import YAMLManifestParser
from debputy.plugin.api import virtual_path_def, VirtualPath
+from debputy.plugin.api.spec import (
+ INTEGRATION_MODE_DH_DEBPUTY_RRR,
+ INTEGRATION_MODE_DH_DEBPUTY,
+)
from debputy.plugin.api.test_api import (
build_virtual_file_system,
)
@@ -65,6 +67,7 @@ def manifest_parser_pkg_foo_factory(
dpkg_arch_query,
no_profiles_or_build_options,
debputy_plugin_feature_set,
+ "full",
debian_dir=debian_dir,
)
@@ -94,7 +97,7 @@ def run_migrator(
manifest: HighLevelManifest,
acceptable_migration_issues: AcceptableMigrationIssues,
*,
- migration_target=MIGRATION_TARGET_DH_DEBPUTY,
+ migration_target=INTEGRATION_MODE_DH_DEBPUTY,
) -> FeatureMigration:
feature_migration = FeatureMigration(migrator.__name__)
migrator(
@@ -1661,7 +1664,7 @@ def test_detect_dh_addons_rrr(
empty_fs,
empty_manifest_pkg_foo,
accept_no_migration_issues,
- migration_target=MIGRATION_TARGET_DH_DEBPUTY_RRR,
+ migration_target=INTEGRATION_MODE_DH_DEBPUTY_RRR,
)
assert migration.anything_to_do
assert migration.warnings == [no_ctrl_msg]