summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/debian/0001-release-check.patch16
-rw-r--r--debian/patches/debian/0002-setuptools-60.patch34
-rw-r--r--debian/patches/debian/0003-systemd.patch33
-rw-r--r--debian/patches/series3
4 files changed, 86 insertions, 0 deletions
diff --git a/debian/patches/debian/0001-release-check.patch b/debian/patches/debian/0001-release-check.patch
new file mode 100644
index 0000000..6386035
--- /dev/null
+++ b/debian/patches/debian/0001-release-check.patch
@@ -0,0 +1,16 @@
+Author: Adam Cécile <gandalf@le-vert.net>
+Description: Disable checking for new upstream releases enabled by default.
+ Users can still enable it through the preferences menus.
+
+diff -Naurp deluge.orig/deluge/core/preferencesmanager.py deluge/deluge/core/preferencesmanager.py
+--- deluge.orig/deluge/core/preferencesmanager.py
++++ deluge/deluge/core/preferencesmanager.py
+@@ -102,7 +102,7 @@ DEFAULT_PREFS = {
+ 'path_chooser_accelerator_string': 'Tab',
+ 'path_chooser_max_popup_rows': 20,
+ 'path_chooser_show_hidden_files': False,
+- 'new_release_check': True,
++ 'new_release_check': False,
+ 'proxy': {
+ 'type': 0,
+ 'hostname': '',
diff --git a/debian/patches/debian/0002-setuptools-60.patch b/debian/patches/debian/0002-setuptools-60.patch
new file mode 100644
index 0000000..6027650
--- /dev/null
+++ b/debian/patches/debian/0002-setuptools-60.patch
@@ -0,0 +1,34 @@
+Author: Stefano Rivera <stefanor@debian.org>
+Description: Import setuptools before distutils (Closes: #1022491).
+ setuptools 60 uses its own bundled version of distutils, by default. It
+ injects this into sys.modules, at import time. So we need to make sure
+ that it is imported, before anything else imports distutils, to ensure
+ everything is using the same distutils version.
+ .
+ This change in setuptools is to prepare for Python 3.12, which will drop
+ distutils.
+ .
+ https://github.com/deluge-torrent/deluge/pull/400
+
+diff -Naurp deluge.orig/setup.py deluge/setup.py
+--- deluge.orig/setup.py
++++ deluge/setup.py
+@@ -12,14 +12,15 @@ import glob
+ import os
+ import platform
+ import sys
+-from distutils.command.build import build as _build
+-from distutils.command.clean import clean as _clean
+-from distutils.command.install_data import install_data as _install_data
+ from shutil import rmtree, which
+
+ from setuptools import Command, find_packages, setup
+ from setuptools.command.test import test as _test
+
++from distutils.command.build import build as _build
++from distutils.command.clean import clean as _clean
++from distutils.command.install_data import install_data as _install_data
++
+ import msgfmt
+ from version import get_version
+
diff --git a/debian/patches/debian/0003-systemd.patch b/debian/patches/debian/0003-systemd.patch
new file mode 100644
index 0000000..6899d78
--- /dev/null
+++ b/debian/patches/debian/0003-systemd.patch
@@ -0,0 +1,33 @@
+Author: n/a
+Description: n/a
+
+diff -Naurp deluge.orig/packaging/systemd/deluged.service deluge/packaging/systemd/deluged.service
+--- deluge.orig/packaging/systemd/deluged.service
++++ deluge/packaging/systemd/deluged.service
+@@ -6,8 +6,9 @@ After=network-online.target
+ [Service]
+ Type=simple
+ UMask=007
+-
+-ExecStart=/usr/bin/deluged -d
++User=debian-deluged
++Group=debian-deluged
++ExecStart=/usr/bin/deluged -d -c /var/lib/deluged/config -l /var/log/deluged/daemon.log -L info
+
+ Restart=on-failure
+
+diff -Naurp deluge.orig/packaging/systemd/deluge-web.service deluge/packaging/systemd/deluge-web.service
+--- deluge.orig/packaging/systemd/deluge-web.service
++++ deluge/packaging/systemd/deluge-web.service
+@@ -7,8 +7,9 @@ Wants=deluged.service
+ [Service]
+ Type=simple
+ UMask=027
+-
+-ExecStart=/usr/bin/deluge-web -d
++User=debian-deluged
++Group=debian-deluged
++ExecStart=/usr/bin/deluge-web -d -c /var/lib/deluged/config
+
+ Restart=on-failure
+
diff --git a/debian/patches/series b/debian/patches/series
new file mode 100644
index 0000000..bc7089b
--- /dev/null
+++ b/debian/patches/series
@@ -0,0 +1,3 @@
+debian/0001-release-check.patch
+debian/0002-setuptools-60.patch
+debian/0003-systemd.patch