summaryrefslogtreecommitdiffstats
path: root/debian/vendor-h2o/misc/regen.mk
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 21:12:02 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-13 21:12:02 +0000
commit77e50caaf2ef81cd91075cf836fed0e75718ffb4 (patch)
tree53b7b411290b63192fc9e924a3b6b65cdf67e9d0 /debian/vendor-h2o/misc/regen.mk
parentAdding upstream version 1.8.3. (diff)
downloaddnsdist-77e50caaf2ef81cd91075cf836fed0e75718ffb4.tar.xz
dnsdist-77e50caaf2ef81cd91075cf836fed0e75718ffb4.zip
Adding debian version 1.8.3-2.debian/1.8.3-2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/vendor-h2o/misc/regen.mk')
-rwxr-xr-xdebian/vendor-h2o/misc/regen.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/debian/vendor-h2o/misc/regen.mk b/debian/vendor-h2o/misc/regen.mk
new file mode 100755
index 0000000..46417e7
--- /dev/null
+++ b/debian/vendor-h2o/misc/regen.mk
@@ -0,0 +1,45 @@
+define FATPACK_SHEBANG
+#! /bin/sh
+exec $${H2O_PERL:-perl} -x $$0 "$$@"
+#! perl
+endef
+export FATPACK_SHEBANG
+
+all: tokens lib/handler/mruby/embedded.c.h lib/http2/hpack_huffman_table.h lib/handler/file/templates.c.h clang-format-all share/h2o/start_server share/h2o/fastcgi-cgi share/h2o/ca-bundle.crt
+
+tokens:
+ misc/tokens.pl
+
+lib/handler/mruby/embedded.c.h: misc/embed_mruby_code.pl \
+ lib/handler/mruby/embedded/core.rb \
+ lib/handler/mruby/embedded/http_request.rb \
+ lib/handler/mruby/embedded/chunked.rb
+ misc/embed_mruby_code.pl $^ > $@
+ clang-format -i $@
+
+lib/http2/hpack_huffman_table.h: misc/mkhufftbl.py
+ python misc/mkhufftbl.py > $@
+
+lib/handler/file/templates.c.h: misc/picotemplate-conf.pl lib/handler/file/_templates.c.h
+ misc/picotemplate/picotemplate.pl --conf misc/picotemplate-conf.pl lib/handler/file/_templates.c.h || exit 1
+ clang-format -i $@
+
+clang-format-all:
+ misc/clang-format-all.sh
+
+share/h2o/start_server: FORCE
+ cd misc/p5-Server-Starter; \
+ fatpack-simple --shebang "$$FATPACK_SHEBANG" -o ../../$@ script/start_server
+
+share/h2o/fastcgi-cgi: FORCE
+ cd misc/p5-net-fastcgi; \
+ fatpack-simple --shebang "$$FATPACK_SHEBANG" -o ../../$@ ../fastcgi-cgi.pl
+
+share/h2o/ca-bundle.crt: FORCE
+ cd share/h2o; \
+ ../../misc/mk-ca-bundle.pl; \
+ rm -f certdata.txt
+
+FORCE:
+
+.PHONY: tokens clang-format-all FORCE