summaryrefslogtreecommitdiffstats
path: root/debian/vendor-h2o/deps/brotli/tests/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/vendor-h2o/deps/brotli/tests/Makefile')
-rw-r--r--debian/vendor-h2o/deps/brotli/tests/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/debian/vendor-h2o/deps/brotli/tests/Makefile b/debian/vendor-h2o/deps/brotli/tests/Makefile
new file mode 100644
index 0000000..8b2eedb
--- /dev/null
+++ b/debian/vendor-h2o/deps/brotli/tests/Makefile
@@ -0,0 +1,19 @@
+#brotli/tests
+
+include ../shared.mk
+
+BROTLI = ..
+
+all: test
+
+test: deps
+ ./compatibility_test.sh
+ ./roundtrip_test.sh
+
+deps :
+ $(MAKE) -C $(BROTLI)/tools
+
+clean :
+ rm -f testdata/*.{bro,unbro,uncompressed}
+ rm -f $(BROTLI)/{enc,dec,tools}/*.{un,}bro
+ $(MAKE) -C $(BROTLI)/tools clean