summaryrefslogtreecommitdiffstats
path: root/debian/vendor-h2o/deps/mruby/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/vendor-h2o/deps/mruby/Makefile')
-rw-r--r--debian/vendor-h2o/deps/mruby/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/debian/vendor-h2o/deps/mruby/Makefile b/debian/vendor-h2o/deps/mruby/Makefile
new file mode 100644
index 0000000..4912f17
--- /dev/null
+++ b/debian/vendor-h2o/deps/mruby/Makefile
@@ -0,0 +1,17 @@
+# mruby is using Rake (http://rake.rubyforge.org) as a build tool.
+# We provide a minimalistic version called minirake inside of our
+# codebase.
+
+RAKE = ruby ./minirake
+
+all :
+ $(RAKE)
+.PHONY : all
+
+test : all
+ $(RAKE) test
+.PHONY : test
+
+clean :
+ $(RAKE) clean
+.PHONY : clean