summaryrefslogtreecommitdiffstats
path: root/doc/example-config/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:36:47 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-15 17:36:47 +0000
commit0441d265f2bb9da249c7abf333f0f771fadb4ab5 (patch)
tree3f3789daa2f6db22da6e55e92bee0062a7d613fe /doc/example-config/Makefile.am
parentInitial commit. (diff)
downloaddovecot-0441d265f2bb9da249c7abf333f0f771fadb4ab5.tar.xz
dovecot-0441d265f2bb9da249c7abf333f0f771fadb4ab5.zip
Adding upstream version 1:2.3.21+dfsg1.upstream/1%2.3.21+dfsg1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc/example-config/Makefile.am')
-rw-r--r--doc/example-config/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/example-config/Makefile.am b/doc/example-config/Makefile.am
new file mode 100644
index 0000000..331d6e9
--- /dev/null
+++ b/doc/example-config/Makefile.am
@@ -0,0 +1,28 @@
+SUBDIRS = conf.d
+
+pkgsysconfdir = $(sysconfdir)/dovecot
+nodist_pkgsysconf_DATA = README
+# nodist_ prefix just doesn't seem to work, so rm it directly:
+dist-hook:
+ rm -f $(distdir)/README
+
+README: README.in Makefile
+ cat $(srcdir)/README.in | sed "s|@exampledir@|$(exampledir)|" > README
+
+exampledir = $(docdir)/example-config
+example_DATA = \
+ dovecot.conf \
+ dovecot-dict-auth.conf.ext \
+ dovecot-dict-sql.conf.ext \
+ dovecot-ldap.conf.ext \
+ dovecot-oauth2.conf.ext \
+ dovecot-sql.conf.ext
+
+EXTRA_DIST = \
+ $(example_DATA) \
+ README.in
+
+install-data-local:
+ $(mkdir_p) $(DESTDIR)/$(pkgsysconfdir)
+
+CLEANFILES = README