summaryrefslogtreecommitdiffstats
path: root/ChangeLog
diff options
context:
space:
mode:
Diffstat (limited to 'ChangeLog')
-rw-r--r--ChangeLog124
1 files changed, 124 insertions, 0 deletions
diff --git a/ChangeLog b/ChangeLog
index 581517d..b768bab 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,127 @@
+2024-08-09 12:24:39 +0300 Aki Tuomi <aki.tuomi@open-xchange.com> (d492236fa0)
+
+ configure: Update version
+
+
+M configure.ac
+
+2024-08-08 15:13:19 +0300 Aki Tuomi <aki.tuomi@open-xchange.com> (9a69ceda23)
+
+ NEWS: Add news for 2.3.21.1
+
+
+M NEWS
+
+2024-04-24 10:45:46 +0000 Marco Bettini <marco.bettini@open-xchange.com> (ce88c33abc)
+
+ lib-mail: message-parser - Limit headers total count to 50MB by default
+
+ (including top headers and all mime-sections headers)
+
+M src/lib-mail/message-parser-private.h
+M src/lib-mail/message-parser.c
+M src/lib-mail/message-parser.h
+M src/lib-mail/test-message-parser.c
+
+2024-04-12 15:06:43 +0000 Marco Bettini <marco.bettini@open-xchange.com> (f020e139c5)
+
+ lib-mail: message-header-parser - Limit header block to 10MB by default
+
+
+M src/lib-mail/message-header-parser.c
+M src/lib-mail/message-header-parser.h
+M src/lib-mail/test-message-header-parser.c
+
+2024-02-09 00:57:12 +0200 Timo Sirainen <timo.sirainen@open-xchange.com> (1481c04f02)
+
+ lib-mail, lib-imap: Optimize parsing large number of address headers
+
+ Every header was appended to a linked list by walking through the whole
+ list, causing excessive CPU usage when the list became large enough. Fixed
+ by changing struct message_part_envelope to use struct message_address_list,
+ which stores also linked list tail pointers. This allows quickly appending
+ to the end of the linked list.
+
+M src/lib-imap/imap-envelope.c
+M src/lib-mail/message-part-data.c
+M src/lib-mail/message-part-data.h
+M src/lib-storage/index/index-search-mime.c
+
+2024-01-30 22:17:38 +0200 Timo Sirainen <timo.sirainen@open-xchange.com> (da61d20311)
+
+ lib-mail: Add message_address_parse_full() and struct message_address_list
+
+
+M src/lib-mail/message-address.c
+M src/lib-mail/message-address.h
+M src/lib-mail/test-message-address.c
+
+2024-02-04 00:26:57 +0200 Timo Sirainen <timo.sirainen@open-xchange.com> (a1c9b04094)
+
+ lib-mail: Change message_address to be doubly linked list
+
+
+M src/lib-imap/imap-envelope.c
+M src/lib-mail/message-address.c
+M src/lib-mail/message-address.h
+M src/lib-mail/test-message-address.c
+
+2024-01-30 22:42:50 +0200 Timo Sirainen <timo.sirainen@open-xchange.com> (0bae091859)
+
+ lib-mail: test-imap-envelope - Use test_assert_idx() where possible
+
+
+M src/lib-imap/test-imap-envelope.c
+
+2024-02-09 00:33:00 +0200 Timo Sirainen <timo.sirainen@open-xchange.com> (cee08202c7)
+
+ lib: Add DLLIST2_JOIN()
+
+
+M src/lib/llist.h
+M src/lib/test-llist.c
+
+2024-02-09 00:32:39 +0200 Timo Sirainen <timo.sirainen@open-xchange.com> (8e4c42dbb3)
+
+ lib: test-llist - Fix dllist2 test name
+
+
+M src/lib/test-llist.c
+
+2024-03-26 14:13:42 +0200 Aki Tuomi <aki.tuomi@open-xchange.com> (57ee018642)
+
+ auth: mech-oauth2 - Use the iterated passdb in oauth2_find_oidc_url()
+
+ Fixes a crash when oauth2 passdb is not first. Broken in
+ 59647f483c49c9e54c43cade168bf10f44a49292
+
+M src/auth/mech-oauth2.c
+
+2024-03-13 13:08:18 +0200 Timo Sirainen <timo.sirainen@open-xchange.com> (b6f4074961)
+
+ login-common: Add client_vfuncs.iostream_change_pre/post()
+
+
+M src/login-common/client-common.c
+M src/login-common/client-common.h
+
+2023-10-06 15:59:32 +0300 Timo Sirainen <timo.sirainen@open-xchange.com> (955bff2155)
+
+ lib: Fix sha2 functions to not produce wrong results with >500MB input
+
+
+M src/lib/sha2.c
+M src/lib/sha2.h
+M src/lib/test-hash-method.c
+
+2023-10-03 13:11:49 +0000 Marco Bettini <marco.bettini@open-xchange.com> (ac2bc5da92)
+
+ oauth: Accept multiple entries in aud field
+
+
+M src/auth/db-oauth2.c
+M src/lib-oauth2/oauth2-jwt.c
+
2023-08-28 15:27:09 +0000 Marco Bettini <marco.bettini@open-xchange.com> (47349e2482)
mail-crypt: mail_crypt_mailbox_allocated() - Force cross-user copies to